[solved] Android app fails with 10RC1


Just did an update a couple hours ago to the latest RC for 10. I have an Android device with the Nexcloud app 1.2.0 installed from F-Droid.

It has ceased working. :disappointed:

The only error I can seem to find is the message it displays “Sync of stack@myhost could not be completed.”

I use DavDroid (also from F-Droid), and it says it syncs the calendar and the contacts, but it isn’t. Changes don’t appear on the server.

So far, all the changes I am making from my Linux computers (and other webdav based applications) are syncing.

Thoughts? What can I do to help troubleshoot the issue?


Totally just remembered an old Android device that I haven’t used in a while. Fired it up, installed the NextCloud client from F-Droid and I can’t even connect to my server. On the “connect” screen when I put in my server I get the error “Unknown error occurred!”.

Going to try the beta client on this device real quick…

Installed beta client 20160809 from F-Droid. Same deal. :worried:

OK. Sorry. PEBKAC error… :blush:

For some odd reason, the majority of my Linux clients kept ticking away like nothing was wrong. My calendar applications were all syncing, my contacts to Thunderbird all worked, everything I tested seemed to work. Until I started poking at my Android device.

When both of those failed, I started thinking “What other devices do I have immediate access to that I can test?” I remembered a laptop shoved into the corner of the office that has an /old/ owncloud client. I fired it up not really expecting much. To my surprise it was complaining about permissions on the server. Huh.

chown apache:apache -R nextcloud/

TADA! Everything connects and works!

I feel so silly on one hand, but on the other I am kinda surprised nothing else mentioned that. Had I gotten that error on Android or any of the other clients, that would have been a 2 minute fix instead of a couple of hours poking around Android…

Anyway. Solved now.
Thanks everyone for the awesome work done on NextCloud. Loving it!

1 Like


I’ve got the same problem on my Nextcloud 10RC (hosted on a shared host on OVH).
Android Client is not working. I get an unknown error when the client check the URL. I can’t see any message into log (even in debug).

All was working before the upgrade with Owncloud

I checked chown, all seems to be correct…

What I don’t understand is that

  • Windows Owncloud client is working (only sometimes a small error when validating URL which I need to do twice).
  • Web Interface is working


  • Android client is not working
  • Web interface on my android is working but I cannot downloid
  • Webdav doesn’t seems to work (tested inside keepass2android)


I would just check all the permissions again on the nextcloud folder. Things like making sure all files are owned by the right user and that the config directory is writable by the user and stuff like that. If they are all correct, then I am not sure as the permissions were what bit me. However, I do completely understand your pain as I found it frustrating to get any type of error worth while out of Android.

Good luck!

I just run a chmod on all files and folder to be sure. No change.
All my files are owned by the same user/group. I can’t change this since I am on a shared host and have only access to FTP to upload my files.

I don’t have too much things on this server, I will try to start from scratch instead of upgrading from Owncloud.

But I still don’t understand why all is working from a PC (web and client, didn’t test webdav) and nothing is working from my mobile (web, client and webdav)… What is the difference between the two access mode!


I didn’t re-install everything but I manage to get :

  • Webdav working with HTTP and HTTPS from totalcommander Webdav plug in on Android
  • Webdav working with cyberduck on http but not with https

It still does not work with http and https from the nextcloud client on Android and from keepass webdav…

When it doesn’t work I get a 503 error service unavailable.

I did some traces on my Android phone. I have seen only one difference. From apps that aren’t working, there are no cookie in the request :

The cookie is set in this first request

When it is working there is a cookie.

Total commander is working because it does a first request without a cookie where he gets a 503 error and the cookie. It then does a new request with the cookie and all is working.


Just to say that I have the same behaviour with the Android client installed via Play Store.
Login step fails at url check with “unknown error” (not so helpful…).

Nextcloud 10.0.0, ovh shared hosting (might be related?).

Not really sure where to go from there, but available for testing!

@Fried can you give the beta version of the Android client a try and after the “unknown error” message post the log from the Android client (can be found in the settings screen)?

@Fried can you access your nextcloud server from within webbrowser on your android phone?

@TobiasKaminsky yes I can access the server from the webbrower on my phone. Desktop sync (with owncloud client 2.2.2) works well too.

@Andy Installed beta from F-Droid store, same issue. Sorry, but where can I get the logs? I can’t see any settings screen, I’m stuck at the login page.

@Fried would you post the servers URL, or DM it to me and @tobiasKaminsky so we can experience the issue & see if we can debug it? If the erros already accours at the server check we don’t need any credentials etc. just the url.

Private message sent!

I get the following error:

09-06 19:40:07.068 10293-10412/com.nextcloud.client E/GetRemoteStatusOperation: Connection check at *********: Operation finished with HTTP status code 503 (fail)

little update: after digging a bit deeper, the issue is in fact the same as in https://github.com/nextcloud/server/issues/223

Related to OVH shared hosting, not the app itself…

Thanks for you support anyway! :slight_smile:

1 Like

For those Android users that encountered this error, see the below solution.

Ensure the two code lines below are in ordered in your Nginx vhost config:

fastcgi_split_path_info ^(.+\.php)(/.*)$;
include fastcgi_params;
1 Like