Social app .well-known/webfinger isn't properly set up!

Hi
I have installed NC20 on ubuntu 18.04 with apache2 in the root directory /var/www/html, and I have configured it with self signed certificate and also configured domain name for it (https://cloud.domain) , after I finished the basics and the system runs with out any problems I have installed the social app but while I started using it I couldn’t follow the users and the users appears in this way USER@USER@{the server IP not the server name} also the social app gives me this warning on the top

.well-known/webfinger isn’t properly set up!

Social needs the .well-known automatic discovery to be properly set up. If Nextcloud is not installed in the root of the domain, it is often the case that Nextcloud can’t configure this automatically. To use Social, the admin of this Nextcloud instance needs to manually configure the .well-known redirects

I have configured the read and write redirection on .htaccess and on the main apache virtual host but the app still gives me the same warning
system logs doesn’t give any thing about this warning also the system check gives me the green check

is it because of the self signed certificate ?

any idea about this ?

1 Like

I am following this. I have this error in the app and in the settings overview. Uninstalling didn’t remove the error from over view. I have since spent a lot of time working on getting it sorted but no go. Would love for this to go away.

I updated to NC 22 yesterday. Now I have the same problem (it didn’t appear with Nextcloud 20). I know Social isn’t officially supported by NC 22, but it seems to work. Just that error is new…

I found a solution after searching for more than an hour… You need to point the webfinger directly to your nextcloud web address. So just enter your Nextcloud adress in the bold-italic part below and copy the line to your .htaccess file in your nextcloud directory.

May not be the best/cleanest solution, but it works.

RewriteRule ^.well-known/webfinger https://www.domain.tld/public.php?service=webfinger [QSA,L]

1 Like