Social app - error upon installation

I wanted to give th eSocial app a try an dconnect o the federated network with diaspora, mastadon, and the like.

I tried downloading the app and I get an error:
Could not extract app social: Out-of-path file extraction {/var/www/clients/client1/web13/tmp/oc_tmp_SZ0RBB-folder/social/vendor/bin/parallel-lint → …/jakub-onderka/php-parallel-lint/parallel-lint}

Might someone be able to tell me in simple terms what the app extraction is doing wrong, and maybe why?

How can I make it work?

Thanks

Joseph

I could ask you for more informations about the underlaying nc-server, os, php, db etc (which would be usually needed to make a sophisticated guess about whats going wrong)

BUT

afaik social-app is a bit faulty and only avail in alpha-version. which is a bit sad.

HI.

Thanks for the reply.

I did not give enough details about my server:

ubunti 20.4
php 7.4
maria db 10.3
apache ??

I use Friendica currently, but I want to try social to see the differences and work on using it a bit to see how it works.

Thanks again for your help.

I am oging to check with the app developpers to see hwo thing are progressing. Friendica is a some what user friendly system to install. I looked a a lot of others, and much server knowledge is needed. Friendica is not too bad. Iam not a server guy, but I was able to get it running.

Social is even easier(I presume) since it is just install and use, once I suceed in installing it:)

1 Like

Hi there

I found the developer github page and after reading hr issues hat are here my issue has been there for awhile. I see comments back to February, though I stopped reading.

I saw talk of compatibility issues going back to v18 of NC. Maybe this is it.

Until we hear news from the developers, we will not know.

Joseph

I’ve found a couple different instructions to manually install the app, but none of them have worked for me.

I am curious if the developper and group of contributors is still even active. It’s been months since they’ve had any activity.

On top of that, with each upgrade to NC, the list incompatibilites will just grow.

Hopefully there will be some activity form the developpers in the near future, It seem slike it has been abandoned. Even if we do get it installed, it seems that no updates or improvements are in store.

I am hoping I am wrong:)

I myself loved the idea behind social app from the beginning on… but it never worked to my statisfaction and so I got pretty much disappointed… like from the beginning on :frowning:

Hello,

At least you got it working back then.

But, had it been slowly developed and improved, things would have gotten better. It is only something like version 0.1, so far from a fully working model.

I wish there was some life happening in the development team. Then there would be, even a minimum, signs of encouragement. I saw no new changes in the code of discussion for the last 8 months.
Time will tell.

Joseph

You would think this would be a pretty high priority with all the folks fleeing from FB and other centralized social media web sites. I remember back in the “old days” when they called Lotus 1-2-3 and WordPerfect “killer apps” because of how they accelerated the use of PC’s. Nextcloud has a prime opportunity to be a leader in this field because some of the others are fairly difficult to set up for some users. I too wish someone would pick this up and go with it.