Snaps Fail after 16.10 Upgrade

Upgraded my x86 server from 16.04.1 to 16.10 today and now none of the snaps are working:

root@NucServer:~# snap list
Name Version Rev Developer Notes
nextcloud 9.0.53snap4 96 nextcloud -
rocketchat-server 0.42.0 86 rocketchat -
snapweb 0.21 18 canonical -
ubuntu-core 16.04.1 423 canonical -
root@NucServer:~# snap run nextcloud
error: cannot find app “nextcloud” in "nextcloud"
root@NucServer:~# snap run rocketchat-server
Segmentation fault
root@NucServer:~# snap run snapweb
Segmentation fault
root@NucServer:~# snap refresh
All snaps up to date.

Deleting and then reinstalling the snaps gives same result. @oparoz I’m guessing there must be a ubuntu-core 16.10 coming down the pipe?

Well, since I don’t work for Canonical, you would be better off asking them. It’s certainly not normal for all snaps to fail like that. Segfaults are major issues…

Please report back so that other users know what to do :slight_smile:

A good option, if you can, is to open an issue on Launchpad and to provide coredumps.

It appears that it was the snapweb snap causing the problem. I tried reinstalling all of my snaps from scratch and realized that my previous version of snapweb was from the beta channel. This time I installed the snapweb stable release and now everything works again. Don’t know why the beta caused segfaults in the other snaps, maybe shared libs?

Refresh didn’t catch my mistake of course, anyone else having this issue should do a snap delete snapweb and then snap install snapweb to get the stable release.

1 Like

Thanks for providing all this information :slight_smile: