SnappyMail - Problems with adding account

Hi,

i got a local server where i use snappymail to manage my mails. In the admin section i configured my two external domains which i want to acceess via snappymail. Both setups are ok and show no errors when i hit the test button.

If i login as a user and try to setup the account for one of the two domains i got this error message: This account already exist [1] But i can not found this account in my list [2]

I´m a bit confused about the error message and have no ideo why this show up. Does anybody got something similiar or an idea for the error messages?

Thanks a lot

Regards
gerribaldi

[1]
image

[2]
image

I’ve run into the same issue. No idea why.

I took a quick look at the issue tracker on GitHub and found the following issue: Cannot add new imap Account - "Account already exists" · Issue #1561 · the-djmaze/snappymail · GitHub

It looks like a fix has already been committed, but a new version with the fix has not yet been released: Resolve #1561 · the-djmaze/snappymail@9ec8ac8 · GitHub

As a temporary workaround until an update is available, you could try to apply the changes manually: Cannot add new imap Account - "Account already exists" · Issue #1561 · the-djmaze/snappymail · GitHub

2 Likes

That workaround fixed it.

I edited the file, added the accounts, and restored the file. Everything works.

Thanks.

1 Like

This works for me also…

Thanks for the link to GitHub :wave:t4:

1 Like

i have now tried something other - 29.0.2. RC2 update also works & you don’t need to modify anything in snappymail code

1 Like