Snappy Nextcloud problem with certificates

Hi everyone,

just for a DISCLAIMER, I am a very new to all of this server and internet stuff.

I am having a problem with enabling HTTPS on my nextcloud domain. So I have installed nextcloud during Ubuntu server installation and it seems it installed it as a snap. I have set up the storage (RAID and all of that), bought a domain, port forwarded the ports 80 and 443 to my server and everything worked beautifully until I ran nextcloud.enable-https lets-encrypt which is the command that was supposed to enable https on nextcloud.

However it printed out an error saying it doesnt have permission for /home/username which I found weird because I ran the command with sudo.

Then I retried the command as root user and it literally broke everything… Now when I tried going to my nextcloud via the domain I bought it was saying something about “self-signed” certificates and then displayed me my router’s webpage.

And now everytime I go to https://mydomain.tld it displays me my router’s webpage and the padlock on the URL bar has a warning saying it isn’t secure.

So I retried the command a couple of times and now I am getting this:

There were too many requests of a given type :: Error creating new order :: too many certificates (5) already issued for this exact set of domains in the last 168 hours: mydomain.tld, retry after 2024-02-05T22:35:46Z: see Duplicate Certificate Limit - Let's Encrypt

I am so confused about whats going on… Can I somehow delete these certificates and retry the command or something? I mean if I have 5 of them already doesn’t that mean my HTTPS should work?

What’s more confusing is that when I run nextcloud.disable-https it displays:
HTTPS doesn’t seem enabled

What can I do about this? Any help is very appreciated! :smile:

Is your router configured to forward the port 443 to your nextcloud server?


This error is from Let’s Encrypt… Snap / Nextcloud / Ubuntu or anything local can’t do anything about it.

Next time, don’t install it via that Ubuntu Installer. Install a clean copy of latest Ubuntu LTS Server, then run following in order.

  1. Update the installation

sudo apt update && sudo apt upgrade -y

  1. Install the Snap Nextcloud

sudo snap install nextcloud

sudo nextcloud.manual-install user password → replace the “user” and “password” with your own.

sudo nextcloud.occ config:system:set trusted_domains 1 --value=192.168.1.xx → Replace that IP with you local Server LAN IP

sudo nextcloud.occ config:system:set trusted_domains 2 --value=xx.xx.xx.xx → Replace it with your static public IP (if you have any)

sudo nextcloud.occ config:system:set trusted_domains 3 --value=domain.tld → replace it with your TLD

  1. Enable SSL

sudo nextcloud.enable-https lets-encrypt → This is after that 168 hours count down…

Otherwise, let’s encrypt is supposed to send you the certificates via that email when you requested the previous attempts. Do you have those in your email? In that case you can use one of that certificates and the relevant files for a manual installation.


I am really sorry for wasting everybodies time here I forgot I even posted this…

I figured out what the issue was, I have created a port fowarding rule for 443 but I have not “enabled” it. So once I did everything worked fine.

Again I’m really sorry if I wasted anybodies time here…