SMTP Einstellungen funktionieren nicht. Fehler: Expected response code 220 but got an empty response

Hallo Leute

Heute wollte ich den SMTP Server einrichten, aber beim Testmail senden kommt immer der Feher: Beim Senden der E-Mail ist ein Problem aufgetreten. Bitte ĂŒberprĂŒfe Deine Einstellungen. (Fehler: Expected response code 220 but got an empty response)

Ich habe als SMTP den Server meines Providers eingetragen mit dem Port 465 (Benutzername und PW natĂŒrlich) Authentifizierung benötigt auch, aber jedesmal beim Testmail senden kommt diese Meldung


Was hab ich ĂŒbersehen??

Ich denke Du hast primĂ€r ĂŒbersehen, dass es auch eine Suchfunktion in diesem Forum gibt :wink:

https://help.nextcloud.com/search?q=smtp

oder

Danke j-ed, ich kenne den Beitrag, aber der verlÀuft sich im Sand.
Ich habe die gleichen Einstellungen wie im meinem Outlook und wie am Smartphone, ich habe auch ohne VerschlĂŒsselung mit Prot 25 probiert, aber es kommt immer die selbe Fehlermeldung.

Edit: im Log ist immer diese Zeile zu sehen: stream_set_timeout() expects parameter 1 to be resource, null given at /data/web/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php#279

Ich selbst habe auch die Erfahrung gemacht, dass eine direkte Kommunikation mit einem externen SMTP-Server Probleme verursachen kann. Ich kann persönlich daher nur empfehlen, die Sendmail-Schnittstelle fĂŒr den Versand zu nutzen.
Wenn man lokal keinen eigenen E-Mail-Server betreibt, kann man sich alternativ z.B. die sSMTP-Software installieren, welche lokal eine sendmail-Schnittstelle bereitstellt, sich aber ansonsten direkt mit einem externen E-Mail-Server verbindet.

Nimm doch localhost als SMTP Server.

Danke Sanook,
auch localhost funktioniert nicht
 war zu erwarten aber ich probier alles :slight_smile: ich betreibe die NC ja auf meinem Webhoster


LĂ€uft auf localhost denn kein Mailserver?

telnet localhost 25

kann ich nicht testen, es gibt keinen Befehl “telnet” wahrscheinlich deaktiviert


netstat -putan|grep ":25 "

netstat: Permission denied

Was sagt der Provider dazu?

Bei mir funktioniert es perfekt mit genau diesen Einstellungen:

Randbedingungen:
NC 15 gehosted bei 1&1 IONOS

Bei schaut’s so aus:

smtp

Hallo @Sanook,

diese Einstellung funktioniert bei mir aber auch nicht, weder mit noch ohne Portangabe.
Bekommst Du dort eine BestÀtigung, dass die E-Mail gesendet wurde?


Gruß
Crashandy

Die Fehlermeldung deutet darauf hin, daß bei dir auf localhost kein Mailserver lĂ€uft.

Ja.