"smbclient" is not installed ubuntu 18.04

Here is my error:

“smbclient” is not installed. Mounting of “SMB / CIFS”, “SMB / CIFS using OC login” is not possible. Please ask your system administrator to install it.

But I have done on snap ubuntu 18.04 “sudo apt-get install smbclient php-smbclient”

Still not working (rebooted)

in my php.ini

allow_url_fopen = On
allow_url_include = Off (this must be On?)

“sud snap set nextcloud php.allow_url_include=On” but is not a valid command (my fault?)


I’m personally not using the snap version but could imagine that you’re using e.g. PHP 7.3, which most likely requires a php73-smbclient module to be installed instead of php-smbclient. Many similar questions about the installation of php modules could be solved the same way. Please use the search function of the forum for further details.

1 Like

It seems php-smbclient

php -v
PHP 7.2.24-0ubuntu0.18.04.4 (cli) (built: Apr 8 2020 15:45:57) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.2.24-0ubuntu0.18.04.4, Copyright © 1999-2018, by Zend Technologies

$ apt-cache search php7.2-*

php-sass - PHP bindings to libsass - fast, native Sass parsing in PHP
php-smbclient - PHP wrapper for libsmbclient
php-solr - PHP extension for communicating with Apache Solr server

If only a “php-smbclient” exists, this doesn’t automatically mean that it has been created for PHP 7.3, most likely it only works with PHP x.?!

Upgraded snap to NextCloud 18.0.4 on ubuntu 18.04
still not working