Slow upload speed when using browser. Fast via webdav client

Nextcloud version: 17.0.0
Operating system and version: Ubuntu Server 18.04.3
Apache or nginx version: nginx 1.17
PHP version: 7.3.10

The issue you are facing:
If I upload 1GB file by using browser (firefox/chrome/edge) or windows file explorer (via webdav) to my nextcloud, my upload speed is about 10 mbps (1.25MB/s).

But if I upload same file using Netdrive 3 or Nautilus file manager (via webdav) upload speed is 45 mbps (5.5MB/s). That’s max upload speed for my internet connection.

Interesting part is that if I upload same file to nextcloud demo ( by using browser I will achive max speeds 45 mbps (5.5MB/s).

My vps with nextcloud is hosted by hetzner. I tested German and Finland for my vps location but no difference. (I’m from Finland)

Note that nextcloud demo is also hosted by Hetzner in Finland. For me at least. I checked it.

I have used Nextcloud playbook to install my nextcloud. Most of the settings are C. Rieger recommendations. So all the perfomance tweaks should be in use by default.

I have tested few nextcloud providers in Europe region and all of them have same problem.
Max upload speed will be 10 mbps (1.25MB/s) when using browser to upload.

I’m not sure what causes this.
Is there problem with my nextcloud settings/configs. Unlikely because I can max out upload using Netdrive/nautilus.
And how nextcloud demo can achive max upload with browser?
I’m confused.

Any ideas about what causes this? Or how to troubleshoot more/fix it?

I know this topic a 2 years old by now, but I had the same problem these days and here is the way I solved this problem. It may help other people in the future.

I had the same situation: fast upload speed when using the Nextcloud Desktop client or using Webdav.

Very Slow Upload Speed (32Kbit/s) when uploading using the browser.

I found out that the slow upload speed was caused by the chunk size.

Large files are normally not uploaded at once as this could cause server timeouts or reach other server limits. Instead, they are split into small chunks.

And here comes the problem: The max chunk size was set to a ridiculous small value (100 Byte). I don’t know why this setting was set to this value, but after I changed the chunk size to a large value, the Browser upload speed was as fast as Webdav and the Desktop Client.

You can read on how to set the chunk size in the nextcloud docs:

1 Like