Slow instance. Bruteforce throttled?

Nextcloud version :
Operating system and version : Debian 11.8, Linux 5.10.0-26-amd64 x86_64
Nginx version : 1.18.0
PHP version : php8.1-fpm on a separate pool. Many children processes allowed.

Nextcloud pages loading time is super long. We can’t barely use Nextcloud.

In settings/admin/overview it says:

There are some errors regarding your setup.

Your remote address was identified as “{ our public IP address behind which almost all of our clients are }” and is bruteforce throttled at the moment slowing down the performance of various requests. If the remote address is not your address this can be an indication that a proxy is not configured correctly. Further information can be found in the documentation :arrow_upper_right:.

The slow nextcloud is for a long time, but maybe this message is there to put my on the way.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'installed' => true,
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'default_language' => 'fr',
  'default_locale' => 'fr',
  'maintenance' => false,
  'loglevel' => 2,
  'theme' => '',
  'default_phone_region' => 'FR',
  'memcache.local' => '\OC\Memcache\APCu',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\OC\Memcache\Redis',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => array(
          'host' => 'localhost',
      'port' => 6379,
      'timeout' => 0.0,
      'password' => '', // Optional, if not defined no password will be used.

hi @itcihef welcome to the forum :handshake:

Please use the search - lot of issues have been discussed already. If there are specific issues or error please describe what you tried so far and which problems you hit!

sounds you want to review reverse proxy docs.

In the admin area you can go to Security and define your IP as whitelisted.
For tests you can disable the brute force app.
After that clear the table bruteforce attempts for quick test. :slight_smile: