Size limit for file drops?

Nextcloud version Nextcloud 23.0.5
Operating system and version Plesk

I have used the file drop feature before and so far it worked. Sometimes others reported problems, but I could never reproduce it and after a while they could use it, so I assume this was some issue on their side.

However, it happened again: Someone who was supposed to deliver files could not upload the files. In the right hand corner a message pops up “Couldn’t upload file xxxxxxx”.

The system still shows the rotating symbol for “uploading”, but nothing happens for hours, and the files are not that huge. So I tested it myself in an incognito window of my browser and with a small PDF file everything worked. Then I tried a bigger video 400MB and after a couple of seconds I got the same error as the other person. A second person reported the same problem, but managed to upload 8 files after reducing their size. This won’t work with the other person, as their files are audio files.

So I just did some updating to make sure there is no other issue. But now, with the latest version I still get the error message with bigger files. I just tested again and it worked fine with a PPT (59kb) and a .m4a file (84 MB), but it immediately stops with a MP4 file of 470MB.

I thought I might have reached the webspace limit, but I don’t think this is the case.

So my other thought is, that there is a file size limit for file drops, but I couldn’t find any setting for this.

I can upload big files (tested with 2GB and 4GB before) without problems as a user in “normal” folders, but via the file drop link it doesn’t work. So it can’t be a general setting in Nextcloud, PHP or the webserver, but it must be specific for the file drop function.

Any ideas?

As a public share (e.g. filedrop) does not use chunked uploads yet (=> file is uploaded in one go) you may hit some limits by your webserver or php.

1 Like

Thanks, that might be an explanation. I will have a look at the articles you have linked and will also have a look at the settings on the server to see if there is any limit that causes problems.