Single user file conflicts on every save/change

Hello everyone,

So, recently I moved form OwnCloud v8 to NextCloud v11 (having already upgraded to v12). My installation of Nextcloud by the way is only used by me and no one else. When I used OwnCloud I never had any problema when saving Office 365 documents, however, it seems that after moving to NextCloud both v11 and v12 I am regularly getting “conflict” files after saving a document.

I can’t seem to figure out any specific pattern in which this happens, but it is quite regular. I open a file, make a change, save and exit, and a conflict file shows up, when I am the only person using nextcloud (no other users). Sometime however I try the same procedure and nothing happens, file is saved correctly.

Anyone have any ideas?

Thanks,

Maybe a silly suggestion, but is the folder where you save the files maybe somehow synchronized twice?
Like for example you added the synchronised folder as an external storage too?

Hello Tom, thanks for your reply. That is however not the case. All storage is one single Samba share that is served via a QNAP NAS.

This issue has been constant and on every version of Nextcloud since v12 till now the latest v13.0.2.

Even thou I am the only user, every time I was working on any file, I would 80% of the time get a conflict.

My set-up is as follows:

  • Raspberry Pi 3
  • Raspbian v9.4
  • MariaDB v10.1.23
  • nginx v1.10.3
  • php v7.0.27
  • File are served via CIFS/SMB from a QNAP NAS

Now, before moving to Nextcloud I was using ownCloud v8 directly on my QNAP. I decided to move to a raspberry pi because the QNAP is very limited. By the way, ownCloud v8 directly on the QNAP worked flawlessly.

I decided on moving to Nextcloud due to the 100% OSS nature of the project, but right from the begining I has issues with conflicts. I tried a little bit of everything. I fine tunned both MariaDB, nginx and PHP to make the best possible use of the hardware available on the raspberry pi, but issue was always present.

I finally decided to try ownCloud v10 on the raspberry, with basically the exact same set-up and configuration, and the issue is no longer present. I no longer have any conflicts when saving and using files.

It seems that I will therefore move back to ownCloud as Nextcloud is aparently unusable by me. What however I always found very strange is that no one else was complaining about this, so it led me to beleive it had to be something isolated to my instalation, but unfortuantely I was never able to understand what and it seems that ownCloud does not suffer from the same issue and so my decision is to move back.

I would test further but unfortunately due to the size of my shares, preparing, testing, indexing, syncing are tasks that take very long, in particular in a raspberry pi.

I know I am digging out an old thread but a user of mine has the same problem: when he works on a file and saves a lot, he always ends up having nextcloud suddenly finding a conflict, and reseting his working copy to a prior version from ~1 hour ago. Any solution to that problem would be welcome.