Share-Link Password-Protect field really slow

Hi guys,

I have a self-hosted nextcloud instance on a Intel i5 PC for a bunch of people. I have Opcache enabled and all internal tests in the Administration->Overview are passed.

I have a problem with the password field when creating a link for a share. When I check the checkbox for Password protection nothing happens:

After roughly 20 seconds, finally the password line appears:


In my understanding this is too long and most users do not understand.

All other elements in the GUI work just fine. E.g. when I click the checkbox for a Expiration Date, the calendar widget appears immediately. Only the password widget takes like forever to appear.

Any hints to speed up things are highly appreciated!

1 Like

Hello m.walz,
I had the same issue. The problem was the DNS setting. Check if your DNS resolution is working correctly.

That is an interesting point!
But can you please be more specific? If your DNS was completely wrong, you could have never reached your site in the first place.

is there already a more detailed solution for this? I am struggling with the same error

Hi having the same issue here, I checked the SQL process list, Apache logs and Nextcloud logs in debug mode but nothing came out clear about what the problem is.
Nextcloud log
{"reqId":"5vi29O9LxzIxfaQGtT1B","level":0,"time":"January 29, 2024 16:53:36","remoteAddr":"","user":"mchouteau","app":"related_resources","method":"POST","url":"/ocs/v2.php/apps/files_sharing/api/v1/shares","message":"flush cache","userAgent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36","version":"","data":{"app":"related_resources"}}

{"reqId":"5vi29O9LxzIxfaQGtT1B","level":0,"time":"January 29, 2024 16:53:36","remoteAddr":"","user":"mchouteau","app":"files_sharing","method":"POST","url":"/ocs/v2.php/apps/files_sharing/api/v1/shares","message":"Share type does not allow to emit interaction event","userAgent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36","version":"","data":{"app":"files_sharing"}}

apache logs - - [29/Jan/2024:17:53:27 +0100] "POST /ocs/v2.php/apps/files_sharing/api/v1/shares HTTP/1.1" 200 1410 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"

The hours don’t match, and I have nothing else in the logs, I’ve tried php-fpm, mysql, syslog.

Maybe you find some informations with browser dev tools. Press F12.

No, I just get the requests without specific errors and the details tell me that the waiting time comes from the server side.

Here on another request and validation of the proposed password (the password protection is enabled on our instance.). We can see that the waiting time is pretty consistent and in total averages 20 seconds to create a link.

I have nothing poping up in the console when I create and validate the password for the link.

I need to take the time to inspect the code responsible for the link creation and the password generation to see where I can inspect the execution and possibly the logs.