Share by link first automatic password

Hi,

We are running 19.0.1.
When sharing something by link, the first time the link is copied to the clipboard but the password field is only showing dots. We have not found any way to copy the first password, we always need to remove password and then create a new one to be able to get the password. Is there any way to obtain this first password when sharing by link?

Thank you.
BR
Zsolt

When you copy the link you can not see the password anymore.
I think you must first copy the plain password and then the link to the clipboard.

Another possiblity is to copy first the link and then set the password.
The link does not change after setting a password.

I also think password makes only sense if you transmit link and password on different ways.
Link with e-amail an password with SMS, WhatsApp or telephone call.
If you email link and password in one or two emails it makes no sense to set a password.

For a bit more secure communication use e.g. the app https://apps.nextcloud.com/apps/guests Then you do not need passwords.

Thanks, we do it that way, we send link by email, pw by WhatsApp.
But to have an auto-generated password copiable, I need to disable password and re-enable it to be able to see it and copy. I wanted to skip this seemingly unnecessary step, since there is already a password generated at the first step.
Zsolt

Yes. But why do yo not create first the public share, copy the public share, then create first password and copy then the first password?

I would not, but when I create a share, the password is auto-generated and the share settings form is not open, so when I open it, the pw is already hidden.
Maybe if there is a way to set the share link not to have a password by default, that would be a solution. But it would be less secure, some users may leave the link without password.

Sorry. But when i crate a share there is no password. I must activate it and then it is auto-generated. Perhaps you have got other settings. In this case perhaps you have no other possibility.

I think you set “Enforce password protection”.

Unbenannt

If you think it is a bug please open an issue at https://github.com/nextcloud/server/issues

I have the following:
image

What is the difference between “Always as for a password” and “Enforce password protection”?

I do not know it. But i think because you automatic set the password you get the problem.

Perhaps you can open an issue at https://github.com/nextcloud/server/issues