Setup Nextcloud on Raspberrypi results in bad gateway

Hello everyone,
I’m completly new to this and any help is really appreciated.
I’m located in germany, if that matters and i try to run a nextcloud on my Raspberry Pi (4 B with 2GB RAM) with ngnix 1.14.2 and MariaDB. I used this https://eigene-cloud-einrichten.de/#vorteile-und-nachteile and this https://eigene-cloud-einrichten.de/nextcloud-installieren-und-einrichten-so-gehts instruction to set up the pi and nextcloud. I use an Telekom Speedport Smart 3 and goip.de as dynDNS client. Until now nextcloud didn’t show up. I just can access it with and 502 Bad Gateway.

Hello @Eastre.

I will try to help you because I don’t speak German!

Have you tried to connect to your server from your local network with a domain name or IP address?

Hey, thanks for your answer.

Yeah sure, they are both in my local network. So I always connect with my laptop to my raspi via ssh.

Please, can we have your ngnix conf files ?

sure, where do I find them?

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
        # SSL Settings
        ##

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/javascript text/xml application/xml applicatio$

        ##

This is nginx.conf
and there is also an empty directory called conf.d

Hi !

There is no configuration for Nextcloudon on your file !

I am not an expert in nginx, you can try to use the official documentation : Nginx configuration — Nextcloud latest Administration Manual latest documentation

If you want want help I’m ready to go on a new install but with Apache or you can wait for someone else to help you.

1 Like

Oh thank you so much :slight_smile:

I will have a look into that! If that doesnt help I will come back again. Would you say apache is overall easier to learn?

Yes I think.

Let me know when you’re ready!