Servidor con Nginx no toma certificado letsencrypt

Buenas a tod@s acabo de instalar en un pc Nextcloud con Nginx MariaDb y dominio NoIp. Todo funciona correctamente pero cuando intento conectar no coge el certificado.

Imagino se deba a una mala configuraci贸n del archivo de configuraci贸n, os dejo como lo tengo .
Si digo de activar la l铆nea # listen [::]:443 ssl ipv6only=on; me da error nginx.

server {
    listen 80;
    listen [::]:80;
    root /var/www/nextcloud;
    index  index.php index.html index.htm;
    server_name  mynextcloud.ddns.net;

    listen [::]:443 ssl; # managed by Certbot
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/mynextcloud.ddns.net/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/mynextcloud.ddns.net/privkey.pem;
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

    location / {
        rewrite ^ /index.php$uri;
    }

    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
        return 404;
    }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
        return 404;
    }

    location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
         include snippets/fastcgi-php.conf;
         fastcgi_pass unix:/var/run/php/php8.1-fpm.sock;
         fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
         include fastcgi_params;
         fastcgi_intercept_errors on;
         fastcgi_request_buffering off;
    }

    location ~ ^/(?:updater|ocs-provider)(?:$|/) {
        try_files $uri $uri/ =404;
        index index.php;
    }

    location ~* \.(?:css|js)$ {
        try_files $uri /index.php$uri$is_args$args;
        access_log off;
    }

    location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
        try_files $uri /index.php$uri$is_args$args;
        access_log off;
    }



}