Server Unavailable on Application Nextcloud Android

Nextcloud version (eg, 20.0.5): 23.0.3
Operating system and version (eg, Ubuntu 20.04): Linux 3.10.0
Apache or nginx version (eg, Apache 2.4.25): Inconnu (hébergement mutualisé)
PHP version (eg, 7.4): 7.4

The issue you are facing:
On my Android (8.0) when I launch the android application I don’t see my documents but the application say : “server unavailable”.
I try to uninstall and a new install and I have the same error.
I try on other Android (9.0) and I have the same error too.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install the application android
  2. Connect to the server
  3. Launch the application

The output of your Nextcloud log in Admin > Logging at the time of the open of application :

[scss_cacher] Debug: SCSSCacher::isCached 35c3-3ead-settings.css dependencies successfully cached for 5 minutes

GET /index.php/settings/admin/logging
from [IP] by [Login ] at 2022-03-30T17:06:47+00:00

[scss_cacher] Debug: SCSSCacher::isCached 35c3-3ead-settings.css isCachedCache is expired or unset

GET /index.php/settings/admin/logging
from [IP] by [Login ] at 2022-03-30T17:06:47+00:00

[scss_cacher] Debug: SCSSCacher::process ordinary check follows

GET /index.php/settings/admin/logging
from [IP] by [Login ] at 2022-03-30T17:01:33+00:00

The output of your Nextcloud log in Admin > Logging with error and IP of phone :

[no app in context] Erreur: Return value of OCA\ServerInfo\OperatingSystems\DefaultOs::getTime() must be of the type string, null returned in file '/home/tendukeb/ajf-nc/apps/serverinfo/lib/OperatingSystems/DefaultOs.php' line 115

GET /ocs/v2.php/apps/serverinfo/api/v1//basicdata?format=json
from [IP] by [Login ] at 2022-03-30T16:58:22+00:00

[PHP] Erreur: shell_exec() has been disabled for security reasons at /home/tendukeb/ajf-nc/apps/serverinfo/lib/OperatingSystems/DefaultOs.php#114

GET /ocs/v2.php/apps/serverinfo/api/v1//basicdata?format=json
from [IP] by [Login ] at 2022-03-30T16:58:22+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'XXXXXX',
  'passwordsalt' => 'XXXXXX',
  'secret' => 'XXXXXX',
  'trusted_domains' => 
  array (
    0 => 'XXXXXX',
  'datadirectory' => 'XXXXXX',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'XXXXXXX',
  'dbname' => 'XXXXXXX',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'XXXX,
  'mysql.utf8mb4' => true,
  'dbuser' => 'XXXXXXX',
  'dbpassword' => 'XXXXXX',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'default_phone_region' => 'FR',
  'has_rebuilt_cache' => true,
  'mail_from_address' => 'XXXXXX',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'XXXXXX',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'XXXXXXX',
  'mail_smtppassword' => 'XXXXXXX',
  'mail_smtpsecure' => 'ssl',
  'versions_retention_obligation' => 'auto,7',

The output of your Apache/nginx/system log in /var/log/____:


Thanks a lot for your help !

Avrc la nouvelle version de l’application, j’ai toujours pas accès au fichiers.

Lorsque je lance l’application

Si je ne fais rien jarrive sur une page sans le menu

J’ai résolu le mystère à force de faire divers tests : L’identifiant de connexion contenait un caractère spécial (pour information & qui avaiy été transformé en &am p; sans espace). Avec tout autre identifiant pas de soucis !

In english : the problem is the caracter & (changed to & amp; without space) for the connection name