Server replied 503 service unavailable to GET

I am getting an issue … tried searching the forum, but could not get much help.

After a bit of struggle, I was able to install NextcloudPi on Raspberry pi 4.
NextCloudPi version = v1.25.0
NextCloudPi image = NextCloudPi_03-28-20

When I am trying to sync the files through MAC client or through the browser, Getting this error on
server replied 503 service unavailable to GET

When I checked the server logs -

Sabre\DAV\Exception\ServiceUnavailable: Could not open file

0. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 90:OCA\DAV\Connector\Sabre\File->get()
1. /var/www/nextcloud/3rdparty/sabre/event/lib/WildcardEmitterTrait.php - line 89:Sabre\DAV\CorePlugin->httpGet(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})
2. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 474:Sabre\DAV\Server->emit("method:GET", [ Sabre\HTTP ... }])
3. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 251:Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})
4. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 319:Sabre\DAV\Server->start()
5. /var/www/nextcloud/apps/dav/lib/Server.php - line 320:Sabre\DAV\Server->exec()
6. /var/www/nextcloud/apps/dav/appinfo/v2/remote.php - line 35:OCA\DAV\Server->exec()
7. /var/www/nextcloud/remote.php - line 167:require_once("/var/www/ne ... p")

looks like a permission issue but not sure where. Tried running sudo chown -R www-data:www-data /media/myCloudDrive , did not fix the issue.

Thanks for your help!