"Server not available" when logging in with SSO in Android app

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 27.1.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): 8.2.10

The issue you are facing:

I set up login with SSO (SAML2) with Auth0 and from the web browser all is working fine. When using the Android app, however, after a successful login, no files are loaded and the message “Server not available” appears. Tried reinstalling, logging out and back in, nothing worked.

Is this the first time you’ve seen this error? (Y):

Steps to replicate it:

  1. Set up login with SSO using the official Nextcloud app
  2. Try to login with the mobile app (Android, don’t have an iOS device to try on)

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'REDACTED',
  'passwordsalt' => 'REDACTED',
  'secret' => 'REDACTED',
  'trusted_domains' =>
  array (
    0 => 'cloud.pcngroup.ch',
  'datadirectory' => '/var/cloud_data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://cloud.pcngroup.ch',
  'dbname' => 'cloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'cloud',
  'dbpassword' => 'REDACTED',
  'installed' => true,
  'integrity.check.disabled' => true,
  'app_install_overwrite' =>
  array (
    0 => 'gluusso',
    1 => 'discoursesso',

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


I think the error lies in the OC\User\NoUserException: Backends provided no user object.

Thank you in advance for your help!
Niccolò Cavallini

1 Like

Did you solve this? I’m having the same problem.


I have something that may be related and I think I found out what it is.
As soon as I place an older svg file, created by an older version of Inkscape (V1.1.1 accoording to the files content), the app shows the message “Server not available”. Very annoying!
Files created or changed by Inkscape version 1.2 do not show this problem.
After a lot of trials and errors I distilled this conclusion.
I use Linux 22.04 Apache Mariadb and Nextcloud Hub 4 26.0.4. Android app version 3.26.0.
It seems to me that the preview function cannot interpret the older files content.
Can anyone acknowledge this?
Is this worth putting in a separate thread?
Does this help anyone?