Server-Installation not found

Hi,
I’ve installed Nextcloud on a place outside the document root of apache2. Concerning the Admin docu I’v created a _nextcloud.con_f using https. A standard browers can log in, however the Android app refuses the connection.

A look in the Apache error log file shows the following entry:

Mon Aug 22 09:28:27.273608 2016] [:error] [pid 5584] [client xxx.xxx.xxx.xxx:36906] script ‘/var/www/html/status.php’ not found or unable to stat

As the Nextcloud-directory is outside the document root the android app certainly cannot find this php-file.

Are there file which must be linked to the document root or ist this the result of faulty configuration?

ThanX
/franzR

But you can use the webinterface? Can you post your nexcloud.conf?

===< config.php >======

$CONFIG = array (
‘instanceid’ => ‘xxxxxx’,
‘passwordsalt’ => ‘ZAb66+sxxxxxx’,
‘secret’ => ‘xxxxx’,
‘trusted_domains’ =>
array (
0 => ‘xxxxx’,
1 => ‘xxxxxt’,
2 => ‘xxxx’,
),
‘datadirectory’ => ‘/media/data/nextcloud/data’,
‘overwrite.cli.url’ => ‘https:/xxx/nextcloud’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘9.0.53.0’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘oc_admin’,
‘dbpassword’ => ‘xxxx’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘enable_avatars’ => true,
‘remember_login_cookie_lifetime’ => 606024*15,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
);

===< nextcloud.conf >======

Alias /nextcloud “/media/data/nextcloud/”

<Directory /media/data/nextcloud/>
Options +FollowSymlinks
AllowOverride All
Require all granted

Dav off

SetEnv HOME /media/data/nextcloud
SetEnv HTTP_HOME /media/data/nextcloud

I just added “Require all granted” for allowing access to directory

WebInterface for browser works well - only the (Android) app does not work with the published configuration

Ok, so your android app queries https://example.org/status.php instead of https://example.org/nextcloud/status.php. When you set up the android app, did you give the complete url (https://example.org/nextcloud)?

edit: your configuration looks good so far.

Aha - it’s my fault because I’ve forgotten to add the URI (…/nextcloud) to URL; no wonder that the applet was searching the ressoures at server’s document root.

Now it works!

ThanX for your support
/franzR