Segmentation fault nextcloud 20.0.9


Our configuration is :
nextcloud 20.0.9
Apache/2.4.38 (Debian)
PHP 7.3.19-1~deb10u1
php -i | grep apc
apc.coredump_unmap => Off => Off
apc.enable_cli => On => On
apc.enabled => On => On
apc.entries_hint => 4096 => 4096
apc.gc_ttl => 3600 => 3600
apc.mmap_file_mask => no value => no value
apc.preload_path => no value => no value
apc.serializer => php => php
apc.shm_segments => 1 => 1
apc.shm_size => 32M => 32M
apc.slam_defense => Off => Off => 0 => 0
apc.ttl => 0 => 0
apc.use_request_time => On => On

when we try the upgrade :
sudo -u www-data php ./occ upgrade
we obtain
Starting …
1/0 [->--------------------------] 0%Segmentation fault
and with the browser also.

Everything on the forum has been tried :
sudo -u www-data php ./occ db: add-missing-primary-keys
sudo -u www-data php ./occ db:add-missing-columns
sudo -u www-data php ./occ db:add-missing-indices
sudo -u www-data php ./occ app:update

with the same result :
Segmentation fault

Please, how we can resolve the upgrade of nextcloud ? Is it a fail of the application ?

you try to upgrade to NC 21? Or a minor version of NC 20?

Hi @tflidd

thank’s for replying.

After a lot of manipulations with the cli occ, I’ve tried with with the web updater, the upgrade worked in 2 steps : 20.0.4 and 21.01 but I still have the error

Migrate old user config
Starting ...
    1/0 [->--------------------------]   0%Segmentation fault

when I run
sudo -u www-data php ./occ upgrade

Other weird thing, running
sudo -u www-data php ./occ file:scan

There are no commands defined in the “file” namespace.

How I can fix this two issues ? There is some tools for auditing the application , it’s hot because I am in production, not testing.


There were issues with the APCU. I’d try just during the update, to comment this part of the config-file and try again.

What kind of system do you use, is it possible that you hit some resource limit?

I’m using Debian GNU/Linux 10 (buster), no I don’t think I am out of resource limit : the server has 62 go of ram, and nextcloud is using merely 5% of it.
I commented in config/config.php
# 'memcache.local' => '\\OC\\Memcache\\APCu',
but same same …

ok, just to make sure it’s not a shared hosting or something like this.

sudo -u www-data php ./occ files:scan

Since it seems related to users, did you use external user authentication or LDAP at some point, or only local users?

You can also check for some old non-existing shares:

check a list of users, perhaps some old users that have been deleted long time ago still remained in the database:

Also check external storage mounts, are there very old ones that aren’t active any more:

Did you move the datafolder?

Is the Nc20 a new setup or was it updated from previous versions before?

1 Like