Security: __Host-Prefix cookie seeting

after upgrading to 15.0.6 i started a security scan - result is A
only one problem __Host-Prefix

Nextcloud is installed in directory nextcloud, whole path ist /mnt/web207/xx/yy/zzzzzzzz/htdocs/nextcloud

xx, yy are alphanumeric numbers
zzzzzzzz is my number from the provider

Nextcloud startpoint is https://mydomain/nextcloud

I searched in the forum, all tips for the error are to change the nextcloud.conf or to move nextcloud to the root

In my installation, theres no nextcloud.conf and moving to root is not possible.

How can I change the config to stop that issue ?

Best regards,

Look at Host Prefix Nextcloud

Thanks, I’ve read the thread. But there is no alias to the nextcloud directory.

In my opinion there is no posibility to set an alias in the webservers conf with strato as hoster.

Only in the .htaccess are 6 lines for nextcloud:

RewriteRule ^\.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L]
RewriteRule ^\.well-known/host-meta\.json /nextcloud/public.php?service=host-meta-json [QSA,L]
RewriteRule ^\.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L]
RewriteRule ^\.well-known/carddav /nextcloud/remote.php/dav/ [R=301,L]
RewriteRule ^\.well-known/caldav /nextcloud/remote.php/dav/ [R=301,L]
Header set Strict-Transport-Security "max-age=16070400"

I’ve set this like the setup guide and the help pages showed.

Moving nextcloud to the root is not an option, there is the primary webpage