Secure nextcloud and collabora


I’m running Nextcloud 28.0.1 on “” and Collabora on “”. Both under docker. It is working well but I’d like to secure it.

I tried the env variable on collabora “” and it doesn’t change anything (if I set domain to something else, I can still open my nextcloud document).

And for nextcloud, I tried to set “Allow list for WOPI requests” but it doesn’t retain the value (the entered value disappear)

I’ve also tried on a fresh install just to be sure, but same problem :frowning:

How can I secure it so my collabora server will be used only with my nextcloud server and that my nextcloud data will not leak?

Thank you


1 Like

Please use the search - lot of issues have been discussed already

It works for me. please review Docker persistent data

is completely outdated :slightly_frowning_face: see more: Important changes regarding COOL/CODE docker versions from v21.11.3.6 on (multiple domains setup)


Thanks a lot for your help. I did search but I haven’t found the solution.

using “aliasgroup” solved my problem for collabora securing.

I still have trouble with “Allow list for WOPI requests”. On the fresh installed nextcloud instance I can set it but on my “old” instance that have been updated, it doesn’t work. (the ip adress automaticcaly disappear :()


It seems to be this issue: [Bug]: Unable to Enter IP in 'Allow List for WOPI Requests' in Nextcloud Admin Settings · Issue #3377 · nextcloud/richdocuments · GitHub

Problem solved, using
docker exec -u 33 -it nextcloud ./occ config:app:set richdocuments wopi_allowlist --value=XXX.XXX.XXX.XXX

1 Like

for me it works using GUI as well, but great you found a way to fix the problem!