Second RC of Nextcloud 28

The second release candidate of Nextcloud 28 is now available on our download server! :rocket:

As always, help with testing is very much welcome!
If you notice anything out of order, please report back on the appropriate github repository! :bowing_woman:

Downloads

Changelog

4 Likes
  • Yess :100:

Update on test server (with very few apps) with both database types, MariaDB and PostgreSQL ran without any problems.

:+1:
ernolf

1 Like

Used the updater to do the update and gets stuck on the “Create Backup”. Resolved it by deleting the updater-xxxxxxxxxxx file about 4 times and seemed to work well after that

(post deleted by author)

Hi @Gustavo1,

please open a new thread here on the forums on your topic. Or, if you wish to get professional support, please get in touch with us.

1 Like

Updated a production instance from 27.1.4 to 28 RC2 with updater.phar without any issues :+1:

2 Likes

This topic is about the Second RC of Nextcloud 28. Please create a new topic to discuss this and don’t hijack this one.

1 Like

This now looks like SPAM to me, as

  1. it has nothing to do with the topic, but
  2. brings up twice now advertising “signature” of commercial service

Maybe you ( @Gustavo1 ) want to think a little about this impact?

Again, this thread is related to “Second RC of Nextcloud 28”, not even a little tiny bit about your question.


Esto ahora me parece SPAM, ya que

  1. no tiene nada que ver con el tema, pero
  2. Ahora aparece dos veces la publicidad “firma” del servicio comercial.

¿Quizás tú (@Gustavo1 ) quieras pensar un poco en este impacto?

Nuevamente, este hilo está relacionado con el “Segundo RC de Nextcloud 28”, ni siquiera un poquito sobre su pregunta.

Sorry, it was my mistake, I have removed the posts. I’m really sorry

2 Likes

@blizzz

Hi Arthur,

Interim report:

  • Issue1:

This release comes with the shipped app files_rightclick version 0.15.1 (or at least its info.xml), which is a version from back in the days it was not yet shipped, meant for server version 14-17.

See:

So it should not exist as a “standalone app” anymore but the old version is installed and shipped.

And the rightclick behaviour is strange, it does not open the context menu near the mouse but near the three dots.


  • Issue2:

While trying to browse the builtin appstore, the main window stays empty, with this error in browser console:

vue.runtime.esm.js:3049 TypeError: Cannot read properties of null (reading 'toLowerCase')
    at AppList.vue:170:1
    at Array.filter (<anonymous>)
    at o.apps (AppList.vue:170:1)
    at e.get (vue.runtime.esm.js:3446:33)
    at e.evaluate (vue.runtime.esm.js:3547:27)
    at o.apps (vue.runtime.esm.js:5541:25)
    at o.hasPendingUpdate (AppList.vue:163:1)
    at e.get (vue.runtime.esm.js:3446:33)
    at e.evaluate (vue.runtime.esm.js:3547:27)
    at o.hasPendingUpdate (vue.runtime.esm.js:5541:25)

Only the “App Bundles” apear and are visible.
I’m entirely suspicious of this issue, as I think it worked fine at first and then suddenly derails on all test servers with the same error

EDIT: This issue dissapeared as fast and misterious as it arised. Now everything is back to normal :thinking:


The same behaviour on all my test servers, tested with php8.1, 8.2 and 8.3, Browsers Opera, Brave, Chrome


  • Issue3:
    When opening the logging tab in admin pannel, window stays empty with this error in browser console (only on one server):
GET https://192.168.188.40/apps/logreader/js/logreader-main.mjs?v=747fec61-2 404 (Not Found)

ernolf

1 Like

Having the same issue with the App Store in NC version 27.1.4 (stable). Apps are no longer visible. Only the the list of ‘Bundles Apps’ is visible.
Running Ubuntu Server 22.04 LTS, PHP 8.1.2, MariaDB 10.6.12
Initially worked without any problem, all Apps visible. Until set of App updates (can not figure out when and which App could effect this behaviour)

All you need to do is wait.
Apparently, some background processes ran and caused this problem.
I had the seem issue with an older version of NC (27.0.1), installed on another server.
Another cause could be a connectivity problem with external NC servers (?). Checked my firewall earlier, without any solutions found.

Yes, the behaviour disappeared.

I could browse the appstore on other servers and with my commandline appstore. apps.nextcloud.com was reachable all the time.

ernolf

1 Like

No, it is not in the release archive:

And checking some upgraded systems, there are no traces either.

I would say it is a left over from an older installation. Double check that your upgrade strategy does not carry over old files other than data and config.

2 Likes

Hm… :thinking:

I did update only with updater.phar and nothing else, to leave it as vanilla as possible.
It looked strange, because it was on all test servers the same. I did not use any not shipped scripts or automations on those servers at all.

Removing the app with occ was possible.

Maybe the state of the app (if enabled or disabled) before running the updater matters?
I did on some point disable it, while it is by default enabled. (Just guessing :woozy_face:)

ernolf

I tried it as well with a production instance:

First I did run into this

Exception: Database error when running migration 28000Date20230906104802 for app core
Index name "ts_session" for table "oc_text_steps" collides with the constraint on table "oc_talk_sessions".

error, which was simple to solve with:

drop index ts_session on oc_talk_sessions;

After that, Update run smooth.

@blizzz : Again the app files_rightclick version 0.15.1 (and not 1.6.0!) was present after the upgrade. :thinking: (I simple removed the app from within the builtin appstore.)

I looked around, some apps, like files_readmemd can not even be activated. After activation. either by builtin appstore, occ or directly by editing the database, it automaticaly deactivates itself. Is that a kind of new security mechanism?
The phonetrac app generates an internal server error. I can’t do without phonetrac.
Other Apps, did not (fully) work, like music. Since the instance in question is used in the music industry it requires and depends on that app, so I restored the snapshot from 27.1.4.
I’ll probably have to wait longer with this update before I can set my productive servers up to it.

More to come …

ernolf

If enabling leads into an Exception, yes. The app needs a fix then.

2 Likes