Script failed to execute on first run (VM)

Support intro

I’m trying to set up NextCloud server on a VM using the image managed by T&M Hansson IT. This is my firs time running it and I tried executing the start script, exactly to their instructions, but it fails.

Nextcloud version :18.0.0
Operating system and version: Windows 10 Latest update

The issue you are facing: Failing to get past the initial step of running the startup script on VMware

Is this the first time you’ve seen this error? I’ve repeated this error on multiple different VMWare instances and also I tried it on VirtualBox but it didn’t work on there either.

Steps to replicate it:

  1. Install VMWare and the NextCloud Image that is managed by T&M Hansson IT]
  2. Follow the instructions to install it. The error will happen just as I start executing the startup-script
  3. It’ll fail after doing a Network check (and saying the connection is fine)

Here is what I saw before the screen says to report it on GitHub. I figured I should try and ask the community before reporting it as an official bug. It’ll be a screenshot of the VMWare window

Also, just to be clear, I didn’t change any settings, and I made sure my network connection was Bridged instead of NAT. I simply imported the .ova file that was provided and followed the instructions.

Thanks for reading

Looks like a bug in the script to me.
No idea if the failed repos trigger that behavior or not.

try fixing the repos, and see if it works then. This is basic linux stuff, maybe you want to search the web for it, as i´m not very handy with broken repos.

Take a snapshot or backup the config files you change before fondling around in there.

@Kupperu Hmm, never seen this one before. I just tested the latest master, and it works here.

Please file an issue report on Github.