SAML Error || Account not provisioned

I have activate SSO/SAML app and after that I can’t login in Nextcloud Admin using the local aacount
error MSG appear " Account not provisioned.Your account is not provisioned, access to this service is thus not possible. "

How can I deactivate it or return back to login using my local account.

any support is appreciated

I’m not an expert, but if you can log into the terminal:

sudo -u www-data php /var/www/nextcloud/occ app:disable user_saml

https://docs.nextcloud.com/server/12/admin_manual/configuration_server/occ_command.html#apps-commands-label

1 Like

Hi,

I am getting the same issue, but I don’t want to disable it. Is there any way to use my own IDP? Means I have my own IDP page, can I redirect the user to this page? If yes then please help me out. Also, the SSO & SAML authentication tab providing limited options. Kindly find the screenshot:

Can I have any update on this?

I ran into the same issue, it appears the ability to select the SSO type in user interface is broken. This results in nextcloud looking for an environment variable from some external SSO framework, which it won’t find, hence giving the ‘not provisioned’ error. What worked for me was running:

UPDATE oc_appconfig SET configvalue=‘saml’ WHERE appid=‘user_saml’ AND configkey=‘type’;

in the mysql backend. After that, I could configure SAML as expected.

configvalue value is already set to ‘saml’ but im still having the same issue.