Sabre\DAV\Exception\BadRequest: expected filesize 10485760 got 2554891

#21

ok - can confirm this happens in a brand new install in a brand new directory without ssl with a basic httpd config and a new mysql database on freebsd-12. only other thing to check i guess is my.cnf

edit; download was directly https://download.nextcloud.com/server/releases/nextcloud-15.0.7.tar.bz2

#22

and it still fails :frowning:

#23

tried with sqlite instead of mysql56-server - still fails, same error. Expected filesize differs if a different file is chosen.

#24

Hello … forum was down for a day! I think I found the answer, it worked for my user anyway.

https://httpd.apache.org/docs/2.4/mod/mod_reqtimeout.html


I added this to my vhost apache .conf and the problem went away:

<IfModule reqtimeout_module>
   RequestReadTimeout body=0
 </IfModule>
#25

heh. fixed my problem thanks firstly to you and also people on the github thread. Here’s what fixed it:


(basically commented out the loadmodule statement for mod_reqtimeout and restarted apache)

One thing that was confusing me though was that on an earlier installation, uploads were working. That one also has reqtimeout enabled and no extra config for it.

thanks again

4 Likes
Unable to rename folder or upload data on Windows 10 mount via WebDav
#26

I confirm this solution too.

To be more precise: The problem with mod_reqtimeout appeared with apache 2.4.39.

I had another identical hosting running 2.4.38 which did not show this problem at all. After updating that one to 2.4.39, it appeared there too.

Thanks to all for your postings!

1 Like