Running out of free space, please help

Hi Guys,

so im experiencing some problems with my nextcloud install.

Im running out of free space although i have a 810gb drive as a boot drive.

I am running nextcloud on a ubuntu server VM inside proxmox.

I will add a couple of pictures since the problem i’m having is probably gonna become apparent from them.



So my df -h puts out a “/dev/mapper/ubuntu–vg-ubuntu–lv” with a sitze of 49gb wich is 84% full.

This is where all of my NC data apparently is stored.

49 gb is the size of my boot drive before i expanded it to 810 gigabytes (see screenshot in second post)

vgs pvs and lvs all refer to this 49gb drive.

How can i expand my ubuntu–vg-ubuntu–lv to use the whole drive?

I tried numerous things and am at a loss right now…

Greetings from Germany.

Please exucse my typos english is not my first language


3rd pic due to first post restrictions here.


After resizing your LVM partition, you should resize your filesystem. For example, this command resize ext2,3,4 filesystem :
resize2fs /dev/mapper/ubuntu--vg-ubuntu--lv

Be careful: you NEVER should have a filesystem size greater than your partition size.

Hey Thom thanks for getting back to me that quick, unfortunately this was among the things i allready tried and just resolves in:


Yep, I just saw your LVM partition size is still 49GB. I don’t know how your resize your hard drive, maybe you miss to resize your LVM volume? Maybe you need to integrate a new gpt/mbr partition to your LVM volume?

well i have no idea to do these things tbh, im still pretty new to linux and do basically everything by google, read, understand and then act :smiley:

First of all, you can see your mbr/gpt partitions size with gparted (gui) or fdisk/gdisk (cli).
If you have unused space, you can extend an existing partition, or create a new one. Then you can resize your LVM partition, then your filesystem.

so i tried gparted, that doesnt work. then i tried fdisk -l which gives me an output and also some sort of error message, seen it before just didn’t bother to research it to be honest.

Maybe this is my error?

Did you try “pvresize /dev/sda3” ?

i did but i get the same output on fdisk - l regardless

so the “dev/mapper/ubuntu–vg-ubuntu–lv” is basically a “virtual disk” inside a virtual disk on sda3? Did i understand that correctly?

You could also boot your VM with a GParted Live ISO. Then you could easily make the changes via the GParted-GUI. This is how I did it when I had to enlarge my virtual disk in Proxmox.

ubuntu–vg-ubuntu–lv is a lvm partition using sda3 because sda3 is (the only) part of ubuntu-vg volume group.

Did you reboot after making changes?

hi guys, just a final entry here:

ended up reinstalling NC completely, apparently i specified a very small partition during installation, so not really a nextcloud issue but rather a ubuntu / linux issue i completely botched myself. After reeinstalling and giving it 100% of my 2tb drive as a “boot” drive i have no issues now :slight_smile:

Thanks for the help anyway!

1 Like