Router not accesible anymore

Nextcloud version (eg, 20.0.5): 1.36.3
Operating system and version (eg, Ubuntu 20.04): Windows10/NextcloudPi
Apache or nginx version (eg, Apache 2.4.25): -
PHP version (eg, 7.4): -

The issue you are facing:

I can’t access my router over webbrowser anymore, all I see is this “Trusted Domains” page: 23 - Album on Imgur.

I let the wizard forward my ports per UPnP and created a FreeDNS subdomain.


letsencrypt gave me this error:

[ letsencrypt ] (Sun Jun 27 16:26:13 BST 2021)
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/nextcloud for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. subdomain. domain. com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http:// subdomain. domain. com/.well-known/acme-challenge/wK7UisXNDwml76G7rwm2EKV3V4MUFLa7-AmNM1Rvsnc: Timeout during connect (likely firewall problem)

So I went to my router to temporarly disable the firewall and deactivate UPnP again. Then I noticed it didn’t save my changes and suddenly after reloading the page I only see this page everytime I try to acces my router 23 - Album on Imgur.

So, yeah. I dont think it’s supposed to be like this? How do I revert it? It seems it forwards the ports even internally now?

Btw im computer literate but public networking/internet isn’t my thing really (yet). Also I have a Pihole which serves as DNS and DHCP if thats important.

What did I do wrong and any way to revert it? (Besides factory reset my router)

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install Nextcloud Pi
  2. Run Wizard
  3. Open Ports on Router per UPnP
  4. Create FreeDNS
  5. Letsencrypt failed
  6. Input E-Mail for letsencrypt
  7. Turn off Firewall for Letsencrypt
  8. Suddenly can’t acces router anymore

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

Try resetting your router to factory default settings, they usually have pin-button you have to press and hold for 5 sec or more.

What IP where you using to access the router?

I never tried pihole, if it is also running dhcp, make sure it is different range then the router.

It’s the default IP DHCP is disabled on the router and only the PI does it.

Are you running ncp itself on Windows 10?

Main issue is… what you are doing is outside of ncp community support. There is no documentation on our end for this process. Of course people can try to help you, but might make more sense to ask letsencrypt or pi-hole community forums.

My .02 is to use containers (Docker) if you plan to run Pi-Hole and NextcloudPi side-by-side. Both will assume they are the only thing running, so easiest method to maintain them is through containers or virtual machines depending on your hardware. This process is also not supported by ncp community documentation, but does work. Either way, good luck to you.

I dont quite understand you. I have 2 seperate PIs. One is running pihole and one I tried to get ncp working. How do they conflict eachother ?