Revert from utfmb4

What would I have to issue to revert from:
ALTER DATABASE nextcloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci ?

Unfortunately, on my shared host I cannot use the required settings for this to work.

I also have this problem.

It would be great if the documentation here:

Edit: I have created a Pull Request to get this information merged into the documentation, you can view the PR here:

Would specify that innodb_file_format=Barracuda is required. I’m also on a shared host and so am unable to change from the default innodb_file_format=Antelope setting.

I managed to roll-back using the following method:

  1. Rolled back the database settings using:
    ALTER DATABASE smartair_box CHARACTER SET utf8 COLLATE utf8_unicode_ci;
  2. Changed the config variable using:
    php occ config:system:set mysql.utf8mb4 --type boolean --value="false"
  3. Rolled-back any databases that had already been converted using:
    php occ maintenance:repair