Restore von NCP in Docker

Guten Abend,

habe zurzeit Nextcloudpi Docker am laufen. Diese Instanz wird alle 3 Tage mithilfe von den NCP Bordmitteln gesichert. Das Update wird in eine *.tar Datei gepackt. Dort befinden sich ein Ordner mit data, Nextcloud und eine nextcloud-sqlbkp_20201207.bak. Angenommen irgendwann wird an NCP nicht mehr weiterentwickelt läuft dieses Projekt aus(zurzeit ist es eig. nur 1 Entwickler), dann möchte ich meine Nextcloud trotzdem weiter betreiben können. Deswegen habe ich mir nun eine Docker-Compose angelegt

Compose.yml

version: ‘3.3’
services:
nextcloud-db:
image: mariadb
container_name: nextcloud-db
command: --transaction-isolation=READ-COMMITTED --log-bin=ROW
restart: unless-stopped
volumes:
- /volume1/docker/test/nextcloud/database:/var/lib/mysql
environment:
- MYSQL_ROOT_PASSWORD=test #SQL root Passwort eingeben
- MYSQL_PASSWORD=test #SQL Benutzer Passwort eingeben
- MYSQL_DATABASE=nextcloud #Datenbank Name
- MYSQL_USER=nextcloud #SQL Nutzername
- MYSQL_INITDB_SKIP_TZINFO=1
networks:
- default
nextcloud-redis:
image: redis:alpine
container_name: nextcloud-redis
hostname: nextcloud-redis
networks:
- default
restart: unless-stopped
command: redis-server --requirepass test # Redis Passwort eingeben
nextcloud-app:
image: nextcloud
container_name: nextcloud-app
restart: unless-stopped
ports:
- 8080:80
depends_on:
- nextcloud-db
- nextcloud-redis
environment:
REDIS_HOST: nextcloud-redis
REDIS_HOST_PASSWORD: test # Redis Passwort von oben wieder eingeben
volumes:
- /volume1/docker/test/nextcloud/app:/var/www/html
- /volume1/docker/test/nextcloud/daten:/var/www/html/data

Die Einrichtung läuft ohne Probleme.
Nach dem erfolgreichem Login setze ich die Instanz in den Wartungsmodus.
Dann werden die data von dem NCP Backup in den Ordner daten kopiert.
Der Inhalt vom Ordner Nextcloud in den Ordner app.
Die mysql stelle ich mit
docker cp /volume1/testsicherung/nextcloud-sqlbkp_20201207.bak nextcloud-db:/dmp
und dann
docker exec nextcloud-db /bin/bash -c “usr/bin/mysql -u nextcloud -ptest nextcloud < /dmp”

damit wäre ja alles wieder wie beim alten oder?

Leider bekomme ich dann immer diverse Fehlermeldungen angefangen von Internen Serverfehler,…
habe es versucht mit der alten und der neun config.php Datei habe es aber einfach nicht hingebkommen.

Was mache ich falsch?

Hoffe mir kann jemand helfen.

MFG Schmidt