I marked the thread as solved because it currently works for me. Maybe I just got lucky and itās some kind of race-condition that sometimes (most of the times actually) leads to the error, but sometimes works. Try restarting againg and again (if you have the time) and see if it works at some point.
Iāve not dared to restart my docker since it is currently running (and I still donāt think I did anything to fix any issue).
Iāll remove the āSolvedā to draw some more attention as this does seem to be still a problemā¦
Iāve just tried to updated my collabora docker container as described at the official website, an I was getting the following errors:
wsd-00026-00026 18:05:30.232264 [ loolwsd ] FTL Failed to fork child processes.| wsd/LOOLWSD.cpp:2703
FATAL: Failed to fork child processes.
wsd-00026-00026 18:05:30.232539 [ loolwsd ] FTL Failed to fork child processes.| wsd/LOOLWSD.cpp:2853
Failed to fork child processes.
wsd-00026-00026 18:05:30.232786 [ loolwsd ] WRN Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507
wsd-00026-00026 18:05:30.232859 [ loolwsd ] WRN Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507
wsd-00026-00026 18:05:30.233457 [ loolwsd ] WRN Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507
wsd-00026-00026 18:05:30.233566 [ loolwsd ] WRN Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.234974 [ loolwsd ] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235091 [ loolwsd ] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235108 [ loolwsd ] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235126 [ loolwsd ] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235142 [ loolwsd ] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235159 [ loolwsd ] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235497 [ loolwsd ] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
<shutdown>-00026 18:05:30.235559 [ loolwsd ] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
frk-00028-00028 18:05:30.239049 [ forkit ] FTL Pipe closed.| common/IoUtil.cpp:308
,which seems similar to the one already mentioned and the container constantly restarts after ~1minute. Iāve recreated the container again and restarted the container and the docker service without any improvements. I also noticed, that the new image is quite a bit smaller:
REPOSITORY TAG IMAGE ID CREATED SIZE
collabora/code latest b953105d9a65 2 weeks ago 1.42 GB
collabora/code <none> 0e6e649ddcae 7 weeks ago 2.06 GB
For now Iāve just reverted to the old image, which works.
Have Iāve been overlooked something on my side or is the docker image broken again?
to cloudShepherd,
I got the same error and found solution - each time you update Collabora image in docker you have to go to web interface of Nextcloud, then to āSettings/Collabora onlineā and just push āApplyā button beneath āCollabora online serverā.