Restarting Docker results in "Failed to fork child processes"


#21

I agree xaasst.
The lack of any transparent versioning, to say nothing of a change list when modifications are made to the docker images makes Collabora close to unusable at this stage.
I have given up trying to get it to work from the docker image for now. I might try a native installation at some point but for the moment I’m just too disappointed from having done what I believe to be the right thing (based on the instructions provided on Collabora and Nextclouds websites), over and over again, trying to amend my own setup to avoid interference, and having arrived at nothing but unhelpful errors like the ones quoted in my previous post…
So my constructive criticism would be:
– Please implement clear, transparent versioning of the CODE docker image.
– Where humanly possible, please list changes somewhere accessible…
– When more time is available, and if possible, please improve the quality of certain error messages (I’m referring in particular to “[ loolwsd ] FTL Failed to fork child processes.| wsd/LOOLWSD.cpp:2590e[0m” which is of no help in tracking down why the fork failed…
Thanks anyway for all the work that seems to be going into developing what is certainly a very much wanted - if not needed - piece of software.


#22

I’m not sure why this is marked as solved.
When I follow the instructions from https://nextcloud.com/collaboraonline/
I get the error in this post.
The docker container just keeps restarting. I am running on a clean install of ubuntu 16.04 LTS with the latest docker-ce


#23

I marked the thread as solved because it currently works for me. Maybe I just got lucky and it’s some kind of race-condition that sometimes (most of the times actually) leads to the error, but sometimes works. Try restarting againg and again (if you have the time) and see if it works at some point.

I’ve not dared to restart my docker since it is currently running (and I still don’t think I did anything to fix any issue).

I’ll remove the “Solved” to draw some more attention as this does seem to be still a problem…


#24

I’m not sure this is a collabora issue. It might be a docker issue.

I had the same problem while running Debian Jessie with the latest version of docker-ce from the docker debian repo.

Then, I purged docker and re-install the ancient version 1.6.2 from debian jessie backports and it all works fine.


#25

I’ve just tried to updated my collabora docker container as described at the official website, an I was getting the following errors:

wsd-00026-00026 18:05:30.232264 [ loolwsd ] FTL  Failed to fork child processes.| wsd/LOOLWSD.cpp:2703                                                                                                             
FATAL: Failed to fork child processes.                                                                                                                                                                             
wsd-00026-00026 18:05:30.232539 [ loolwsd ] FTL  Failed to fork child processes.| wsd/LOOLWSD.cpp:2853                                                                                                             
Failed to fork child processes.                                                                                                                                                                                    
wsd-00026-00026 18:05:30.232786 [ loolwsd ] WRN  Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507                                                                         
wsd-00026-00026 18:05:30.232859 [ loolwsd ] WRN  Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507                                                                         
wsd-00026-00026 18:05:30.233457 [ loolwsd ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                    
wsd-00026-00026 18:05:30.233566 [ loolwsd ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                    
<shutdown>-00026 18:05:30.234974 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235091 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235108 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235126 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235142 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235159 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235497 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235559 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
frk-00028-00028 18:05:30.239049 [ forkit ] FTL  Pipe closed.| common/IoUtil.cpp:308

,which seems similar to the one already mentioned and the container constantly restarts after ~1minute. I’ve recreated the container again and restarted the container and the docker service without any improvements. I also noticed, that the new image is quite a bit smaller:

REPOSITORY          TAG                 IMAGE ID            CREATED             SIZE                     
collabora/code      latest              b953105d9a65        2 weeks ago         1.42 GB                  
collabora/code      <none>              0e6e649ddcae        7 weeks ago         2.06 GB

For now I’ve just reverted to the old image, which works.
Have I’ve been overlooked something on my side or is the docker image broken again?


#26

to cloudShepherd,
I got the same error and found solution - each time you update Collabora image in docker you have to go to web interface of Nextcloud, then to “Settings/Collabora online” and just push “Apply” button beneath “Collabora online server”.