Resolve "/.well-known/caldav"

I know this has been asked many times. I’ve read through many different threads, and still haven’t figured this out.

The warning I get in the NC admin panel:

  • Your web server is not properly set up to resolve “/.well-known/caldav”. Further information can be found in the documentation :arrow_upper_right:.
  • Your web server is not properly set up to resolve “/.well-known/carddav”. Further information can be found in the documentation :arrow_upper_right:.

This is a new install:

  • nextcloud 27.0.2
  • apache 2.4.57-2
  • Debian Bookworm (12).

I have installed nextcloud in a subdirectory, i.e., My DocumentRoot is /var/www/html. mod rewrite is enabled.

Following the documentation, my .htaccess file in the document root (/var/www/html/.htaccess) contains the following:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^.well-known/carddav /nextcloud/remote.php/dav [R=301,L]
RewriteRule ^.well-known/caldav /nextcloud/remote.php/dav [R=301,L]
RewriteRule ^.well-known/webfinger /nextcloud/index.php/.well-known/webfinger [>
RewriteRule ^.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo [R=>

I restarted apache2 via systemctl restart apache2 to make sure the settings are updated.

I have tried many different variants suggested in various threads here, without resolving this issue. Some of them suggest different syntax for the .htaccess file, or that I need to configure something in /etc/apache2. Most of it includes a strong air of desperation and confusion, so I’m not sure what we’re all missing.

Any pointers would be greatly appreciated!

Your web server is not properly configured to resolve “/.well-known/something.

Hello @plantarum

There may be different variants here, but we use these to solve the problem:

We create with

sudo nano /etc/apache2/sites-enabled/000-default-le-ssl.conf
A new config file and add the following content:

<IfModule mod_headers.c>
  Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; strict-origin; preload"
  Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
  Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Since the NextCloud is in the subfolder /nextcloud in our case, you have to specify this folder. If you have not followed our instructions, you can omit the /nextcloud.

To be on the safe side, we are now also changing the document root of the default ssl file

sudo nano /etc/apache2/sites-available/default-ssl.conf
to /var/www/wordpress.

Then that would be solved!

Hope this guide will help you. Feel free to visit our website; there are several troubleshooting guides.

Best regards,

https://url.schä and

Hi @SchBenedikt

That did it, thank you so much!

I’m not using wordpress, so I didn’t make the second change.

I read a lot of tutorials in addition to the documentation, but I guess I should have looked at the German language ones instead :slight_smile:

Hi @plantarum
Thanks for the nice answer!
We especially want to present working instructions on our websites with our tutorials that fix every error.
So if you should have problems again, we would be happy about a visit!

Hi again,

I just checked my server for the first time in a month or so (it’s been working with no problems at all, so I didn’t think anything was amiss).

The admin panel reports the nodeinfo and webfinger warnings again. I haven’t changed the config, or had any other problems, so I don’t know what has changed. It did tell me that 27.1.0 was available, so I updated to that. No issues, everything still works, but the warnings persist.

Any other ideas to fix this?