Remove link "Get your own free account"

Hello everyone!

Since the last update there is the following saying at the bottom of split pages: “Get your own free account”. This doesn’t seem very professional for my customers. How can I remove this link again? I didn’t find a way.

3 Likes

Uh,

I don’t believe there is a way except going back to a older version.

1 Like

Do you have screenshot? I did not found this on my NC.

It only appears on pages that have been publicly linked. The slogan is normally visible to the target person. If you are logged in, you do not see it.

Check it in: ../core/templates/layout.public.php

1 Like

Add this in /path/to/nextcloud/config/config.php:

  'simpleSignUpLink.shown' => false,

Problem solved!

13 Likes

Thank you!
What should I do in this code?

Changing to “false” has no effect at all:
grafik

1 Like

Just test it and it works immediately after change. Did you change your config.php under .../config/config.php?

I’m getting more and more confused. In the meantime I have heard of three places where I should change something:

  • config\config.sample.php
  • config\config.php
  • Templates\layout.public.php

The text “‘simpleSignUpLink.shown’ => false,” is only in the “config.sample.php”. The “false” has no effect.

Can someone please explain to me exactly what I have to do where to make the text “Get your own free account” disappear on the shared pages?

Only this is place where your config saved. Added 'simpleSignUpLink.shown' => false, there.

The text “‘simpleSignUpLink.shown’ => false,” is not in the “config.php”. Do I have to insert the complete line there again? If yes, where?

Ok. I have now set “‘simpleSignUpLink.shown’ => false,” in “config.sample.php” to “true” again. At the end of “config.php” I added a new line with the text “‘simpleSignUpLink.shown’ => false,”. Now it seems to work. I’ll probably have to repeat this after every update.

Now there is only my own slogan at the bottom. In contrast to before, the slogan is no longer bold on the split pages (and only there). Can I change that somewhere?

Glad to see it works for you. Remember all configs are under …/config/config.php. Documentation is here: https://docs.nextcloud.com/server/14/admin_manual/configuration_server/config_sample_php_parameters.html
Regarding this parameter I open a ticket, it was not listed in the doc and I did not know about it also.

1 Like

Is this workarround still working?
I cannot remove this link by editing the config.php file

1 Like

Still works.

Is there a layout cache of some sort that needs to be cleared? Have changed this setting to false in config.php and it is not having any effect.

Ok, so, after changing this value I also had to restart all the containers (i.e. delete the Kubernetes pods and let the deployment recreate them), then drop our Redis cache in order for the setting to have an effect. I am guessing layouts get precompiled/cached in some way.

1 Like

is there a ticket opened for this somewhere?

The link is so annoying

  • you can’t get free accounts on my cloud
  • the link leads to a different server (nexcloud.com) which has no affiliation to my server
  • nextcloud does not allow for signup anyway…
1 Like

Instead of posting to this old topic you should have read it.

Post #13 gave you a link and information which could easily bring you to

Closing this here.