does not display NC tasks

Hi all!

today I have a nearly 2h call with the Apple support. We figured out, that the sync work if I start my Mac in Secure Mode (start with pressed Shift key). The conclution was that some application block the connection.

After the call I tried a few things and found out that my issue was caused by Little Snitch (5.0.4). When I disable the Little Snitch network adapter in system preferences the sync work also in normal Mode. I wrote the Little Snitch support. I will report here when I got an answer…


That’s a bit strange and is great info.

After reading your post, I also tried starting up with Shift held, and sure enough, it works. However, I don’t have Little Snitch installed. I do have the Cisco AnyConnect VPN client installed though, and after removing that, it started working fine.

I wonder if there is still a bug at the OS level that causes it not to function when any network filter driver is installed.

1 Like

Hi psychotic! I still have no feedback from the Little Snitch support. I will send them your info! Hopefully they have a better relationship with the Apple Devs/Support than I do. Don’t want to spent 2 more hours exlaining it some low level supporter… :wink:

Hi all! I got info from the Little Snitch support. They reported and/or follow other bugreports of the problem related to “Third-Party Network Extensions and Cloud Services” at Apple. Hope Apple take care of the problem soon…


Wow. Big big thank you for this information!

I didn’t try the secure mode, but after the description of you two I could guess some network issue. As I’m not using any of your tools, I’m using TripMode (which blocks network traffic during mobile connections). The TripMode network adapter seems to be active all the time even if the program is not running.
After deactivating this adapter in the network seetings, the tasks are synchronising.

Since TripMode isn’t that important for me currently, I will leave it deactivated for now.

Thank you again for your contribution and your effort calling the apple support as this has a big influence on my daily workflow :+1:



1 Like

Apple released macOS 11.2 yesterday. I’ll try if the Update hopefully solve the issue and share it here what I’ve found out…


Since disabling Little Snitch is not a real solution, I do not mark the subject solved for now.
I stay tuned for a working update of MacOS / Little Snitch that fix this issue.

Hooray! My Reminders sync with macOS Big Sur 11.2 and Little Snitch enabled! :grinning:


I confirm, updating to macOS Big Sur 11.2 solve the issue.


Solved for me as well after update to 11.2. :grinning: :+1:

For me, using MacOS Big Sur 11.2.1, the is still not showing any task from Nextcloud.
I started using the Mac just with BigSur a few days ago, never had a Mac before.

Take a look at does not display NC tasks - #3 by j-ed

To see tasks in Reminders, the Nextclould server have to use a valid (as defined by Apple) SSL certificate.

Same problem here! Has not worked since Big Sur was released… I use a Let’s Encrypt certificate, which apparently conforms to the cert requirements… But it doesn’t work. Tried various things suggested here, but does not work. Perhaps it will work again in Monterey?

Following up on this: I lost Calendar on iOS now (Cannot Connect Using SSL). Calendar does appears to work perfectly fine on macOS!

Hi everyone,

I’ve got an interesting update to this topic regarding the iOS “Cannot Connect Using SSL” problem. When I proxy what the OS does using Charles, it makes the following requests:

Screenshot 2021-11-01 at 13.38.03

So there are 405s. I wonder if these now need to be fixed with redirects? I tried adding the following to .htaccess:

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule ^principals /remote.php/dav/principals/ [R=301,L]
  RewriteRule ^calendar/dav/(.*)/user /remote.php/dav/principals/users/$1/ [R=301,L]

I wasn’t sure what to do about the / request, though. It doesn’t make any difference though, unfortunately…

Revert the redirects you added. The 405s are not your problem.

/.well-known/caldav should redirect to /remote.php/dav and not to /

You need to fix that first and then see if there are any errors remaining.

Hi @Bernie_O,

Thanks for your response. Yes, I reverted those, it was just an experiment. However, my redirect does appear to work:

$ wget "" 2>&1 | grep "Location"
Location: [following]

… so it is a bit confusing that macOS tries to hit those other URLs. I don’t have another version I can test with, though…

The redirect needs directly to go to https://.....
Fix that and then check again for errors.

Oh my! That is indeed in, @Bernie_O ! Thank you very much for your help. This must be because my Nextcloud is behind an Apache reverse proxy that provides all the SSL.

I tested by changing to:

<IfModule mod_rewrite.c>
	RewriteRule ^\.well-known/caldav https://%{HTTP_HOST}/remote.php/dav/ [R=301,L]

… and everything else. Now I just need something clean to add to the end of .htaccess that makes sure all URLs are https. I tried

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

But this leads to a redirect loop… Any ideas on that one?

Sorry, I can’t help with the apache configuration.