Regarding some question with text in nextCloud app on IOS system

Opening .md file from nextCloud results in blank

The operation process is as shown below

nextCloud server :28.05
IOS nextCloud:

I have tried uninstalling the app and reinstalling it, but the problem still exists

about logs

{“reqId”:“jFAAZXIgDmJR6RMQoxOv”,“level”:3,“time”:“2024-04-29T01:56:55+00:00”,“remoteAddr”:“”,“user”:“adam”,“app”:“PHP”,“method”:“GET”,“url”:“/index.php/core/preview.png?file=tiger-cloud/”,“message”:“file_get_contents(/web/ Failed to open stream: No such file or directory at /web/”,“userAgent”:“Mozilla/5.0 (iOS) Nextcloud-iOS/5.2.7”,“version”:“”,“data”:{“app”:“PHP”}}

{“reqId”:“jFAAZXIgDmJR6RMQoxOv”,“level”:3,“time”:“2024-04-29T01:56:55+00:00”,“remoteAddr”:“”,“user”:“adam”,“app”:“index”,“method”:“GET”,“url”:“/index.php/core/preview.png?file=tiger-cloud/”,“message”:“Exception thrown: OCP\Files\GenericFileException”,“userAgent”:“Mozilla/5.0 (iOS) Nextcloud-iOS/5.2.7”,“version”:“”,“exception”:{“Exception”:“OCP\Files\GenericFileException”,“Message”:“”,“Code”:0,“Trace”:[{“file”:“/web/”,“line”:74,“function”:“getContent”,“class”:“OC\Files\Node\File”,“type”:“->”},{“file”:“/web/”,“line”:73,“function”:“getContent”,“class”:“OC\Files\SimpleFS\SimpleFile”,“type”:“->”},{“file”:“/web/”,“line”:190,“function”:“getImage”,“class”:“OC\Preview\GeneratorHelper”,“type”:“->”},{“file”:“/web/”,“line”:110,“function”:“generatePreviews”,“class”:“OC\Preview\Generator”,“type”:“->”},{“file”:“/web/”,“line”:187,“function”:“getPreview”,“class”:“OC\Preview\Generator”,“type”:“->”},{“file”:“/web/”,“line”:173,“function”:“getPreview”,“class”:“OC\PreviewManager”,“type”:“->”},{“file”:“/web/”,“line”:96,“function”:“fetchPreview”,“class”:“OC\Core\Controller\PreviewController”,“type”:“->”},{“file”:“/web/”,“line”:230,“function”:“getPreview”,“class”:“OC\Core\Controller\PreviewController”,“type”:“->”},{“file”:“/web/”,“line”:137,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/web/”,“line”:184,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/web/”,“line”:315,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:“::”},{“file”:“/web/”,“line”:1069,“function”:“match”,“class”:“OC\Route\Router”,“type”:“->”},{“file”:“/web/”,“line”:39,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/web/”,“Line”:56,“message”:“”,“exception”:{},“CustomMessage”:“Exception thrown: OCP\Files\GenericFileException”}}

The editing in the web-interface works?

In such cases, I’d always double check if a file with only standard ASCII characters work.

Do you have the preview generator app installed? If yes, does it work when you disable it (the errors are related to the preview, not sure if that can prevent editing, ideally it should not).

It is possible to use the PC web page, and even through the developer mode, there is no problem simulating the IOS 14 system.

I tried it and the problem still exists even if I change the default encoding.

I’m not sure if the preview generator app is installed. How do I confirm whether this plug-in is installed?

You can see it in the app overview page, what app is enabled.

I found an issue that looks a bit similar:

But not a lot of people are affected. Anything special, theming? Or do you use a proxy that perhaps block certain requests?

My problem seems to be the same as the one described here
However, I just restored the theme to default, but it still cannot be opened.
In addition, below are the plugins I am using. Please help me check if there is any problem.

I also found another interesting problem, as shown in the video I recorded
Cannot view the text application that is opened normally
But if you clear the cache first, then on the settings page, click on the homepage, and apply text again, you can view it, but if you look closely, it seems that it is not the same as the actual effect. In addition, this operation can only be done once.

Record screen

Caching is used a lot to improve the speed of Nextcloud. I had similar effect with some bugs that were fixed but only after browser caches were properly cleaned.

ok, good.

I don’t get that point. Now the text editor should work all the time, no?

On a web browser, it’s basically possible.
However, occasionally there is a problem of being unable to connect to the server.
In addition, when you close the text app and refresh the browser, the text app just opened will be opened again. But these seem to have nothing to do with the current problem