REDIS 'timeout' => 0.0?

Hello, I have now successfully integrated a REDIS server in NC.
I do not understand the following entry in the config.php:
‘timeout’ => 0.0,
Make users write using the following value:
‘timeout’ => 1.5,
Other users leave this entry altogether.

What exactly does that mean? What does this value stand for? And which value makes sense?
Thank you.

I think this question can be answered by following the recommendation in the administrator guide to consult the Redis documentation for further details about the timeout parameter.

I already knew the documentation. Thank you. Nevertheless, I do not understand the value 0.0. If I interpret correctly, the client connection will be disconnected immediately. Or does 0.0 never mean? And what value is automatically set if you do not have a timeout for redis in the config?
I’ve installed Redis because of issues with shared Office files that have been open for several hours by users in Office via WebDAV. This had the effect that the shares were eventually deleted automatically. Very uncool.
I hope with Redis to get this problem under control.
Thank you.

Here’s what’s used in the Nextcloud VM:

Redis works for me. This can easily be controlled in NC as follows:
“redis-cli MONITOR”
But my main concern is my problem with the Office files mentioned above.
My config:

‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘localhost’,
‘port’ => 6379,
‘filelocking.enabled’ => ‘true’,

If you read the Redis documentation, you have seen this:

Client timeouts

By default recent versions of Redis don’t close the connection with the client if the
client is idle for many seconds: the connection will remain open forever.
However if you don’t like this behavior, you can configure a timeout, so that if the client is
idle for more than the specified number of seconds, the client connection will be closed.

So, if you don’t set the parameter in the Nextcloud configuration file I would expect that a disconnection will not be forced.

Ok, I understood that.
But why should you and not

'timeout' => x.x,

That makes no sense then and contradicts?

Please refer:

For best performance, use Redis for file locking by adding this:
‘memcache.locking’ => ‘\ OC \ Memcache \ Redis’,

Small organization, single server setup
Use APCu for local caching, Redis for file locking:

‘memcache.local’ => ‘\ OC \ Memcache \ APCu’,
‘memcache.locking’ => ‘\ OC \ Memcache \ Redis’,
‘redis’ => array (
‘host’ => ‘localhost’,
‘port’ => 6379,

Nextcloud can be used from personal environments up to enterprise wide systems with several thousands of users. Therefore a single “one fits all” setting doesn’t exist and the adminstrator need to decide if it makes sense to use the default setting or not.

Many thanks