Redis test on Nextcloudpi

Good evening,

how i can test if my reddis work in my nextcloudpi instance(docker).

If i try: redis-cli I get the following error: Could not connect to Redis at 127.0.0.1:6379: Connection refused. Same error if i try redis-cli monitor.

The nextcloudpi web panel says redis is ok.

My redis config in the config.php:
“memcache.local”: “\OC\Memcache\Redis”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “REMOVED SENSITIVE VALUE”,
“port”: 0,
“timeout”: 0,
“password”: “REMOVED SENSITIVE VALUE
},

did you tried this on your host? you have to run redis-cli inside of your container. with docker exec ...

btw: if redis is configured in config.php and it’s not working, nextcloud won’t work either. you’ll get a blank page or an error message.

thanks for your answer.

the redis server is include in the nextcloudpi docker.

I tried the command inside the nextcloudpi docker.

port: 0 means redis is only available via socker. did you the appropriated parameters with redis-cli?

that means redis-cli tried to connect via tcp. which is most likely disabled in the setup.

I doesen’t change anything.

I just want to test if the redis work.

did you tell redis-cli to connect via socket?

redis-cli -s /path/to/socket

I guess the host entry that you removed is the path to the socket:
'host' => '/run/redis/redis-server.sock',

Do you mean
redis-cli -s /var/run/redis/redis.sock monitor
this doesen’t work. I get (error) NOAUTH Authentication required.

yes

so redis is working. you just have to add the password. i guess it’s -p ... but not sure.

thanks in --help it says it’s -a but it doesen’t work.

When you say nextcloud doesen’t work without reddis then the reddis must work.

you should see a redis-server process when you enter ps -ef | grep redis

if you see this process and nextcloud is working, everything is fine.

if you want to test: change the socker path in the config.php so nextcloud can’t use redis or kill the redis-server. with both tests a reload of the nextcloud page should fail.

on your own risc. :wink:

i killed the process and then i get an error on my nextcloud.

Thanks for your help.