REDIS Error after Updating to NCPv1.54.2

Hello,
after updating to NCP v1.54.2, I get the following error messages in the Nextcloud log every time I restart:

[bruteforcesettings] Fatal: Error during app loading: LOADING Redis is loading the dataset in memory
von ? von – um 10.05.2024, 12:18:45

{“reqId”:“SCe54t5Sob235WuMgwIr”,“level”:4,“time”:“2024-05-10T10:18:45+00:00”,“remoteAddr”:“”,“user”:“–”,“app”:“bruteforcesettings”,“method”:“”,“url”:“–”,“message”:“Error during app loading: LOADING Redis is loading the dataset in memory”,“userAgent”:“–”,“version”:“28.0.3.2”,“exception”:{“Exception”:“RedisException”,“Message”:“LOADING Redis is loading the dataset in memory”,“Code”:0,“Trace”:[{“file”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“line”:76,“function”:“get”,“class”:“Redis”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/autoloader.php”,“line”:154,“function”:“get”,“class”:“OC\Memcache\Redis”,“type”:“->”},{“function”:“load”,“class”:“OC\Autoloader”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php”,“line”:217,“function”:“class_exists”},{“file”:“/var/www/nextcloud/lib/private/App/AppManager.php”,“line”:397,“function”:“isBootable”,“class”:“OC\AppFramework\Bootstrap\Coordinator”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/App/AppManager.php”,“line”:213,“function”:“loadApp”,“class”:“OC\App\AppManager”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_App.php”,“line”:125,“function”:“loadApps”,“class”:“OC\App\AppManager”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Console/Application.php”,“line”:114,“function”:“loadApps”,“class”:“OC_App”,“type”:“::”},{“file”:“/var/www/nextcloud/console.php”,“line”:99,“function”:“loadCommands”,“class”:“OC\Console\Application”,“type”:“->”},{“file”:“/var/www/nextcloud/occ”,“line”:11,“args”:[“/var/www/nextcloud/console.php”],“function”:“require_once”}],“File”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“Line”:76,“message”:“Error during app loading: LOADING Redis is loading the dataset in memory”,“exception”:,“CustomMessage”:“Error during app loading: LOADING Redis is loading the dataset in memory”},“id”:“663df4bae3789”}

[core] Fehler: Exception thrown: RedisException
GET /.env.example
von 31.7.62.226 von – um 10.05.2024, 12:18:45

{“reqId”:“Zj30gmnz_Gjio81yQcEyyQAAAEY”,“level”:3,“time”:“2024-05-10T10:18:45+00:00”,“remoteAddr”:“31.7.62.226”,“user”:“–”,“app”:“core”,“method”:“GET”,“url”:“/.env.example”,“message”:“Exception thrown: RedisException”,“userAgent”:“Mozilla/5.0 (Linux; Android 9; SAMSUNG SM-G965W Build/PPR1.180610.011) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/9.4 Chrome/67.0.3396.87 Mobile Safari/537.36”,“version”:“28.0.3.2”,“exception”:{“Exception”:“RedisException”,“Message”:“Redis server /var/run/redis/redis.sock:0 went away”,“Code”:0,“Trace”:[{“file”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“line”:76,“function”:“get”,“class”:“Redis”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/URLGenerator.php”,“line”:203,“function”:“get”,“class”:“OC\Memcache\Redis”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/template/functions.php”,“line”:249,“function”:“imagePath”,“class”:“OC\URLGenerator”,“type”:“->”},{“file”:“/var/www/nextcloud/core/templates/layout.guest.php”,“line”:20,“function”:“image_path”},{“file”:“/var/www/nextcloud/lib/private/Template/Base.php”,“line”:180,“args”:[“/var/www/nextcloud/core/templates/layout.guest.php”],“function”:“include”},{“file”:“/var/www/nextcloud/lib/private/Template/Base.php”,“line”:150,“function”:“load”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_Template.php”,“line”:139,“function”:“fetchPage”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_Template.php”,“line”:170,“function”:“fetchPage”,“class”:“OC_Template”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Template/Base.php”,“line”:132,“function”:“fetchPage”,“class”:“OC_Template”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_Template.php”,“line”:258,“function”:“printPage”,“class”:“OC\Template\Base”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/base.php”,“line”:1126,“function”:“printErrorPage”,“class”:“OC_Template”,“type”:“::”},{“file”:“/var/www/nextcloud/index.php”,“line”:39,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“Line”:76,“CustomMessage”:“Exception thrown: RedisException”},“id”:“663df4bae384c”}

[core] Fehler: Exception thrown: RedisException
PROPFIND /remote.php/dav/files/malte/
von 79.193.0.5 von – um 10.05.2024, 12:18:45

{“reqId”:“Zj30hI7iSVcKq-IIKdjuRgAAAAE”,“level”:3,“time”:“2024-05-10T10:18:45+00:00”,“remoteAddr”:“79.193.0.5”,“user”:“–”,“app”:“core”,“method”:“PROPFIND”,“url”:“/remote.php/dav/files/malte/”,“message”:“Exception thrown: RedisException”,“userAgent”:“Mozilla/5.0 (Windows) mirall/3.13.0stable-Win64 (build 20240423) (Nextcloud, windows-10.0.19045 ClientArchitecture: x86_64 OsArchitecture: x86_64)”,“version”:“28.0.3.2”,“exception”:{“Exception”:“RedisException”,“Message”:“Redis server /var/run/redis/redis.sock:0 went away”,“Code”:0,“Trace”:[{“file”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“line”:76,“function”:“get”,“class”:“Redis”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/autoloader.php”,“line”:154,“function”:“get”,“class”:“OC\Memcache\Redis”,“type”:“->”},{“function”:“load”,“class”:“OC\Autoloader”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Server.php”,“line”:1170,“function”:“class_exists”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“line”:175,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:“->”,“args”:[“*** sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:122,“function”:“OC\AppFramework\Utility\{closure}”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:142,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/ServerContainer.php”,“line”:173,“function”:“query”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“line”:64,“function”:“query”,“class”:“OC\ServerContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Server.php”,“line”:2112,“function”:“get”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Server.php”,“line”:1360,“function”:“getThemingDefaults”,“class”:“OC\Server”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“line”:175,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:“->”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:122,“function”:“OC\AppFramework\Utility\{closure}”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”,“args”:[" sensitive parameters replaced ***”]},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“line”:142,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/ServerContainer.php”,“line”:173,“function”:“query”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“line”:64,“function”:“query”,“class”:“OC\ServerContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/public/Server.php”,“line”:55,“function”:“get”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_Template.php”,“line”:80,“function”:“get”,“class”:“OCP\Server”,“type”:“::”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_Template.php”,“line”:281,“function”:“__construct”,“class”:“OC_Template”,“type”:“->”},{“file”:“/var/www/nextcloud/remote.php”,“line”:92,“function”:“printExceptionErrorPage”,“class”:“OC_Template”,“type”:“::”},{“file”:“/var/www/nextcloud/remote.php”,“line”:174,“function”:“handleException”}],“File”:“/var/www/nextcloud/lib/private/Memcache/Redis.php”,“Line”:76,“CustomMessage”:“Exception thrown: RedisException”},“id”:“663df4bae3b77”}

Does anyone have any idea what is causing this error and how to fix it?

I am using NextCloudPi 28.0.3 on a Raspi4.

Thank you very much,

Malte

Somehow I can’t figure out the error.
I have now updated to Nextcloud 28.0.5. After the error didn’t go away, I reinstalled Redis:

sudo apt-get install --no-install-recommends php8.1-redis
Paketlisten werden gelesen… Fertig
Abh▒ngigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
php8.1-redis
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 56 nicht aktualisiert.
Es m▒ssen 174 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 182 kB Plattenplatz zus▒tzlich benutzt.
Holen:1 Index of /php/ bullseye/main arm64 php8.1-redis arm64 6.0.2-1+0~20231128.56+debian11~1.gbp9f3071 [174 kB]
Es wurden 174 kB in 1 s geholt (180 kB/s).
Changelogs werden gelesen… Fertig
(Lese Datenbank … 43827 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von …/php8.1-redis_6.0.2-1+0~20231128.56+debian11~1.gbp9f3071_arm64.deb …
Entpacken von php8.1-redis (6.0.2-1+0~20231128.56+debian11~1.gbp9f3071) ▒ber (5.3.7+4.3.0-1+0~20220330.42+debian11~1.gbp6fe8b7) …
php8.1-redis (6.0.2-1+0~20231128.56+debian11~1.gbp9f3071) wird eingerichtet …
Trigger f▒r php8.1-fpm (8.1.12-1+0~20221028.28+debian11~1.gbpc35f51) werden verarbeitet …
NOTICE: Not enabling PHP 8.1 FPM by default.
NOTICE: To enable PHP 8.1 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php8.1-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Trigger f▒r php8.1-cli (8.1.12-1+0~20221028.28+debian11~1.gbpc35f51) werden verarbeitet …

After every reboot I get the message for Core and different apps. And when I ping Redis, I get the following error:

redis-cli ping
Could not connect to Redis at 127.0.0.1:6379: Connection refused

But Nextcloud is running and I Sys-Info shows no errors. Redis is also shown as OK. Only the NCP web panel is extremely slow.

NextcloudPi version v1.54.2
NextcloudPi image NextCloudPi_RaspberryPi_v1.50.3.img
OS Debian GNU/Linux 11. 5.15.76-v8+ (aarch64)
automount no
USB devices sda
datadir /data/nextcloud
data in SD no
data filesystem ext2/ext3
data disk usage 184G/458G
rootfs usage 4,3G/15G
swapfile /var/swap
dbdir /data/sqldata
Nextcloud check ok
Nextcloud version 28.0.5.1
HTTPD service up
PHP service up
MariaDB service up
Redis service up
HPB service up
Postfix service up
Internet check ok
Public IPv4 -----
Public IPv6 not found
Port 80 open
Port 443 open
IP -----
Gateway -----
Interface eth0
Certificates none
NAT loopback no
Uptime 4min