Redis cluster error without having a cluster

latest nextcloud hoellen/nextcloud docker 22.0
PHP 7.3
nginx 1.20.1
redis 6.2.5 single instance

long running and working nextcloud recently autoupdated via watchtower

since then, i have a white screen and nothing else.

occ update:check shows

occ update:check

An unhandled exception has been thrown:
Exception: Redis cluster config is missing the “seeds” attribute in /nextcloud/lib/private/RedisFactory.php:86
Stack trace:
#0 /nextcloud/lib/private/RedisFactory.php(164): OC\RedisFactory->create()
#1 /nextcloud/lib/private/Memcache/Redis.php(43): OC\RedisFactory->getInstance()
#2 /nextcloud/lib/private/Memcache/Factory.php(115): OC\Memcache\Redis->__construct(‘fe784447876118a…’)
#3 /nextcloud/lib/private/Server.php(1051): OC\Memcache\Factory->createLocking(‘lock’)
#4 /nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\Server->OC{closure}(Object(OC\Server))
#5 /nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility{closure}(Object(Pimple\Container))
#6 /nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet(‘OCP\Lock\ILocki…’)
#7 /nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query(‘OCP\Lock\ILocki…’, fal

as i haven’t a redis cluster configured and nothing in the config.php i’m a little screwed here…
neither google nor forum search revealed something.
Is redis cluster mode now mandatory with ver 22?

1 Like


seems like a bug to me. I am facing the same issue.

Temporary fix:

I changed the line in lib/private/RedisFactory.php from
$isCluster = in_array('redis.cluster', $this->config->getKeys());
$isCluster = false;

Did you open an issue at the GIT repo?


Just started having the same error. I had to disable redis from config.php for it to stop working. (My whole installation was Erroring 500). It then prompted me with update 22.1.0. I did the update and all is working!

I am going to check to see if I can enable it again.


I faced the same issue, disable redis config didn’t works for me
I’m using docker image so I can’t change RedisFactory.php manually (previous docker image must be removed to upgrade)

So I’m totally stick with a broken installation

Upgrade to

You can change the file, just run this command:

docker exec -ti <containername> /bin/bash

This opens a shell inside the container. Now you can change the file.


Yes of course, thanks

This bug should reappears with the next update

Just ran into the same error with update to 22.1.1.
Had to apply the mentioned workaround.

Modifiying the RedisFactory.php got me an integrity check error in the NC Gui.


  • core
      • lib/private/RedisFactory.php

Raw output

[core] => Array
[lib/private/RedisFactory.php] => Array
[expected] => 82e3c6edd20a84764a25b70c45f2a21923f5fd81987d7456ba93c8c9cc358d1457d10d8f085f82c9a5aef46e90f90032d8f55a1baa7cade4718432ad6ddbc95b
[current] => 7843cc64d0ef68c5f6375e641eaa7f1127cddf09e4acdcff76bfae10218cbe9b5f8d44cb6cf8bc62da75463da3e8680cb4ccdf44c47236c029eff7831ea7134f





Same error for me too, after update from to current 22.1.1.

Debian 10, php 7.4, nginx, Maria db

Before never a similar error happened

After changes in the RedisFactory i was able to complete the update, but now also the integrity check error at admin

Is there a fix in the next update?

Same here on Ubuntu 20.04.3 LTS with nextcloud snap.

Same - DEB10

UPDATE - Mine was related to an improper S3/DigitalOcean Spaces implementation.

I was using some guidance I’d found elsewhere, and the code block for mounting the space was incorrect. I updated to the information in the Nextcloud Admin Guide, and viola.

Hello! I have some problems with temporary fix. When I try make any changes in lib/private/RedisFactory.php, I can’t do this, cause file is unwritable. Also I can’t change permissions because: “chmod: changing permissions of ‘RedisFactory.php’: Read-only file system”. Please help me to solve this problem.