Redis cluster error without having a cluster

latest nextcloud hoellen/nextcloud docker 22.0
PHP 7.3
nginx 1.20.1
redis 6.2.5 single instance

long running and working nextcloud recently autoupdated via watchtower

since then, i have a white screen and nothing else.

occ update:check shows

occ update:check

An unhandled exception has been thrown:
Exception: Redis cluster config is missing the “seeds” attribute in /nextcloud/lib/private/RedisFactory.php:86
Stack trace:
#0 /nextcloud/lib/private/RedisFactory.php(164): OC\RedisFactory->create()
#1 /nextcloud/lib/private/Memcache/Redis.php(43): OC\RedisFactory->getInstance()
#2 /nextcloud/lib/private/Memcache/Factory.php(115): OC\Memcache\Redis->__construct(‘fe784447876118a…’)
#3 /nextcloud/lib/private/Server.php(1051): OC\Memcache\Factory->createLocking(‘lock’)
#4 /nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\Server->OC{closure}(Object(OC\Server))
#5 /nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility{closure}(Object(Pimple\Container))
#6 /nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet(‘OCP\Lock\ILocki…’)
#7 /nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query(‘OCP\Lock\ILocki…’, fal

as i haven’t a redis cluster configured and nothing in the config.php i’m a little screwed here…
neither google nor forum search revealed something.
Is redis cluster mode now mandatory with ver 22?

1 Like

Hi,

seems like a bug to me. I am facing the same issue.

Temporary fix:

I changed the line in lib/private/RedisFactory.php from
$isCluster = in_array('redis.cluster', $this->config->getKeys());
to
$isCluster = false;

Did you open an issue at the GIT repo?

Regards

Just started having the same error. I had to disable redis from config.php for it to stop working. (My whole installation was Erroring 500). It then prompted me with update 22.1.0. I did the update and all is working!

I am going to check to see if I can enable it again.

Hello

I faced the same issue, disable redis config didn’t works for me
I’m using docker image so I can’t change RedisFactory.php manually (previous docker image must be removed to upgrade)

So I’m totally stick with a broken installation

Upgrade 22.0.0.11 to 22.1.0.1

You can change the file, just run this command:

docker exec -ti <containername> /bin/bash

This opens a shell inside the container. Now you can change the file.

Regards

Yes of course, thanks

This bug should reappears with the next update

Just ran into the same error with update to 22.1.1.
Had to apply the mentioned workaround.

Modifiying the RedisFactory.php got me an integrity check error in the NC Gui.

Results

  • core
    • INVALID_HASH
      • lib/private/RedisFactory.php

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[lib/private/RedisFactory.php] => Array
(
[expected] => 82e3c6edd20a84764a25b70c45f2a21923f5fd81987d7456ba93c8c9cc358d1457d10d8f085f82c9a5aef46e90f90032d8f55a1baa7cade4718432ad6ddbc95b
[current] => 7843cc64d0ef68c5f6375e641eaa7f1127cddf09e4acdcff76bfae10218cbe9b5f8d44cb6cf8bc62da75463da3e8680cb4ccdf44c47236c029eff7831ea7134f
)

            )

    )

)

Thx

Same error for me too, after update from 21.0.4.1 to current 22.1.1.

Debian 10, php 7.4, nginx, Maria db

Before never a similar error happened

After changes in the RedisFactory i was able to complete the update, but now also the integrity check error at admin

Is there a fix in the next update?

Same here on Ubuntu 20.04.3 LTS with nextcloud snap.

Same - DEB10

UPDATE - Mine was related to an improper S3/DigitalOcean Spaces implementation.

I was using some guidance I’d found elsewhere, and the code block for mounting the space was incorrect. I updated to the information in the Nextcloud Admin Guide, and viola.

https://docs.nextcloud.com/server/stable/admin_manual/configuration_files/primary_storage.html?highlight=primary%20storage

Hello! I have some problems with temporary fix. When I try make any changes in lib/private/RedisFactory.php, I can’t do this, cause file is unwritable. Also I can’t change permissions because: “chmod: changing permissions of ‘RedisFactory.php’: Read-only file system”. Please help me to solve this problem.

Same issue here first time after update to 22.1.1 and still there after update to 22.2.0 today. The temporary fix from Shadow256 (thanks a lot!) did work for me, but how does the final solution look like?

BR, LostInTranslation

Hi there! Same issue here.
Shadow256 temporary fix also was my solution. Tnxs!

Did anyone made a bug report to follow?
tnxs in advance.

Same here, took me a while to find this topic but the temporary solution worked for me as well.

1 Like

Worked for me, THANKS!

to update from 21.0.5 to 22.2
i change RedisFactory.php
to
$isCluster = false;

update work to 22.2

now
Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • lib/private/RedisFactory.php

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[lib/private/RedisFactory.php] => Array
(
[expected] => 9e88f3c5d116ca81cf01725c1ce68f09d2e9b9d8798d30ae487ac674c5eb160cbf6962bb638e318d7f785d89a723a0d0ba4f0f4a34c47fd098f3c0b7e259957c
[current] => b1b57deb6191e722a5dffbf12be82cbaed871df683e5b08621d59216661244fe221580738e48802d77169efeb2e22a268b7a277e42629bf7e88febea45f42e34
)

            )

    )

)

who can help ?

22.2.2 still the same bug
In which release will be the fix for this?

As stated before I’m running the nextcloud snap on ubuntu 20.04.3 LTS and since nextcloud 22.2.0snap2 i’m not observing the failure anymore and I do not have to apply any of the above workarounds (Neither code change related to $isCluster = ... nor the redis changes in config.php). None of them seems to be to be permanently applied in the new release either. So it must have been some other change, that is fixing the situation for me. I can see that various redis binaries in ./bin/redis-* have changed - no idea wtether that fixed things.

I have a second snap instance in my LAN that has not suffered from the problem at all, not even with version 22.0 or 22.1.

1 Like

from 22.2.2 to 22.2.3 the same bug !

Can confirm that the bug still exists in 22.2.3. I updated yesterday and once again the update process crashed in the middle (to be precise the moment the RedisFactory.php got overwritten with the default file from the installation package).

I had to apply the Shadow256 (KUDOS for your work!!! ) during the update, refresh the update and it went to the end. Now I have the same integrity check error again as posted by MikeZuluUSA here.

My setup (note: no docker image - standard server installation):
Ubuntu 20.04 LTS
MariaDB
Apache
PHP 7.4

As asked before by someone else: Is there a bug report in place or does the issue already have some dev-attention? I can more ore less just C&P what is already in this thread because I have the exact same error-situation, so I’d like to be more redundant than just confirming the issue (for I am not that experienced in posting professional bug reports).