Rclone mount inside nextcloud

Hey guys, I’m actually try to mount a rclone google drive into my Nextcloud user folder.
i run the actual Nextcloud and installed it with the installation script in ubuntu 20
what i done:
created a cron job who run as root user and mount the folder at system start into my user directory. the command i use is:
/sbin/start-stop-daemon -S -u root -d /root --exec /usr/bin/rclone mount gcrypt:crypt/ /mnt/ncdata/Xyz00777/files/cloud – --allow-other --allow-non-empty --cache-db-purge --buffer-size 32M --use-mmap --dir-cache-time 72h --drive-chunk-size 32M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &
now i have the problem that the mount is working but Nextcloud don’t show the folder inside my user webview not even the cloud folder.
when i do these command:
sudo -u www-data php /mnt/ncdata/Xyz00777/files/cloud/ occ files:scan --all
i got no output. have anybody a idea what i can do or what i done wrong?


i would mount the google drive outside the nextcloud data dir. and use the “external storage support / local path” to make the files available inside nextcloud. didn’t test it.

and the owner of that mounted folder has to be your web server user (www-data).

p.s.: you may use markdown language to quote commands. with a bit formatting your post is easier to read. :wink:

oh yes your correct :smiley:
with the flag --allow-other i allow other users to access the date of these drive, i will try to give the folder where the drive will get mounted www-data but i think that will get overriden when i mount the drive

what about the --uid and --gid option of rclone mount ?

okay after around 2 hour testing many stuff… i found out that i forget a letter in the path for the external drive inside nextcloud…
after i ccorrected the path i mount the it with rclone as root with the option --allow-other and now it works ^^

1 Like