Raspberry Pi 5 Docker Installation - unable to use second external USB-Drive

[/details]

Nextcloud version: Nextcloud Hub 7 (28.0.2)
Operating system and version: Linux 6.1.0-rpi8-rpi-2712 aarch64
Operating on: Raspberry Pi 5 Model B Rev 1.0 (4 cores) 8GB RAM
PHP version: 8.2.15

Hi y’all,
first things first, I’m not as tech-savvy as many of you, I don’t work in IT and half of the time I don’t know what I’m doing when using instructions. But I’m always happy to learn and to understand the context of what I’m doing. So be gentle. :wink:

The Backstory:
After setting up NextcloudPi on a RaspPi 4 for personal use and personal data storage (esp. contacts and calendar), I bought a Raspberry Pi 5 a few days ago to set up a nextcloud for voluntary-work-projects, meaning other users should have access. Well, only to discover that NextcloudPi doesn’t yet run on a Pi5… Mince, alors! But I found a pretty neat instruction for setting it up via docker while mounting an external USB-Drive (Link here, but in German). It works fine an all data is on the external USB-Drive (~250gb).

The Problem:
Since I’m very paranoid, I want to regulary backup all data on a second USB-Drive (~500gb). I followed different instruction, even set up the nextcloud a second time, but the secon drive doesn’t show up in the System-view. I tried to mount it with the external drive App anyway (the path exists and it is mounted according to the backend), but it won’t recognise the path.

Here’s what I did:
First I tried to mount it together with the first drive in the same way as the installation instruction told me to. Of course I used another mounting point.

If used disk - Remove all data & partitions from disks

parted /dev/sdb “rm 1”

Check if no partitions are on disks

lsblk

Create GPT Table

parted /dev/sdb “mklabel gpt”

Create partition on disk

parted /dev/sdb “mkpart primary ext4 1M -1”

Create Datasystem on drive

mkfs -t ext4 /dev/sdb1

Create Mount Directory

mkdir /mnt/backup

add by UUID

blkid

nano /etc/fstab

UUID=613d508b-fe9c-419d-98b4-xxxxxxxxxx /mnt/ssd ext4 defaults 0 1

mount drive

mount -a

check mount

df -Th

I also tried to mount it as a media folder (like here). Of course after unmounting it first.

mkdir /media/backup
UUID=613d508b-fe9c-419d-98b4-xxxxxxxxxx /media/backup ext4 rw,users 0 0

mount the drive

mount -a

Verify drive is mounted:

df -h

Create folder for ncdata

sudo mkdir /media/backup/ncdata
sudo chown www-data:www-data /media/backup/ncdata

The last step was probably not necessary, I think. But I checked between steps and it didn’t show up in the System-View.

I also used another way, according to an instruction video (Link).

lsblk
fdisk /dev/sdb
mkfs -t ext4 /dev/sdb1
mkdir /mnt/disk2
mount /dev/sdb1 /mnt/disk2

According to the video the disk should be shown under “System”. Well, it didn’t. :frowning: Since there was no instruction for editing fstab, the disk was unmounted after reboot.

Maybe someone has an idea what else I could do or where I did something wrong.

BONUS-QUESTION
I also own a Synology-NAS and learned, that I can upload data via Cloud-Sync and WebDav. But alas, as far as I understand, there is no way to upload all settings/calendar-data etc. etc. or a way to simply recover the Nextcloud after a USB-Drive dies? If someone knows a way to use the NAS to fully update, that would be another possibility without a second USB-Drive.

Thanks in advance!
-gil

So this is getting rediculous. I invested most of yesterday in finding another solution with my Synology-NAS. Neither SFTP- nor WebDAV-Synchronisation seems to work. If I connect the NAS via SFTP, the data-app doesn’t show folders anymore and if I connect it via WebDAV I can’t read or write in the shared folders…
I get Warnings about protocoll errors since 7th February, while I have installed th docker image yesterday evening. Plus a lot of PHP-Modules seem to be missing, another thing I tried to solve without any luck.

So either I’m far less tech-savvy than I thought I was or the Raspberry Pi5 isn’t ready for Nextcloud?

My solution now is to use the Pi5 for Kodi and my Kodi Pi4 for NextcloudPi. When NCP is out for Pi5 I’ll switch it back.