Random Server Error 500

I recently upgraded my server and updated & upgraded my Ubuntu and now I am getting:
`Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.`

Ive checked the logs and i dont see anything at all. I haven’t changed anything yet ive got this error, does anyone know a way to fix this?


There should be more details in the webserver log, or the webserver error log. Perhaps the log levels need to be increased so you see more errors. Also check if the file system is full.

I recently upgraded my VPS, got more storage from 200GB to 800GB, only after this has it started having a paddy :smiley:

If you increase the number of files, tables get larger, many things need more resources and if certain things are not optimized, e.g. you don’t use caching, it can quickly go bad. Logfiles should give hints, also documentation:

Memcached is installed and the log is smth like 20GB, cant rlly open it as its a very large file xD

Then you might want to use logrotate to keep your logfiles small.

How would I do this?

I deleted my log file a few days ago, its made a new one with no info in, ive tried accessing the site, but no logs show up. Same stupid error. All i did was upgrade my VPS & storage, same disc, etc. just larger

For the internal server error, you usually have entries in the log files. You can also change the log levels, perhaps most of the messages are disabled. If you use php-fpm, this can log in different locations. Check the paths and log levels in the web server configuration.

On my apache site .conf I dont see anything for logging, what would I have to add and where would I find php-fpm logs? Im on Ubuntu 18.04

I honestly dont get why this has happened, everything was fine, i upgrade storage and now my site is down.

Did you update your OS as well? Or is it the same setup?

No my OS hasnt been changed, I just upgraded my VPS. So more storage, more CPU cores, more RAM, better internet speeds. So this shouldnt have affected it at all.

Ive fixed it, ran this command:
All fixed now

sudo -u www-data php --define apc.enable_cli=1 /var/www/nextcloud/occ maintenance:repair

Also disabling this in the config also seemed to work:

‘memcache.local’ => ‘\OC\Memcache\APCu’,