Quick help: unable to upload large files (Nginx)

Hi everyone,
I hope you can help me out. I am running Nextcloud in the dockerized version and have a nginx reverse proxy for SSL support in from of that setup. I am running all this with docker-compose and everything is running fine. But I am unable to upload large files. With the mobile app I am able to upload everything, but with the Windows client not. The error is “request entity too large”. I have googled the problem and it seems that the nginx is not able to handle large files somehow (even if the mobile app is working…). So I want to increase the size nginx can handle to 500 MB.
I have tried this to manually configue the default.conf file, but obviously thos will be overwritten as this file is dynmically created. I have tried the method described in the readme, added “client_max_body_size 500m;”
in that file, added this of course in my volumes for docker-compose but thats also not working…
I am out of ideas, maybe you one for me?
Thanks :slight_smile:

1 Like

Anyone?

Would be great.
Cheers

You will have to change the maximum file size in PHP as well. Consult your OS’s PHP documentation for more info about location of the file you will have to edit.

Solved it my setting “- ./proxy/custom/my_proxy.conf:/etc/nginx/conf.d/my_proxy.conf:ro” in docker-compose. Inside the file I have added “client_max_body_size 256m;” and it was working :slight_smile: