Question on Antivirus with GData

Dear Fellows,

from the beginning ever since, it worked seemless to configure Antivirus to use our GData Business solution.
I just chose “clamav executable”, pointed the path to /usr/bin/gdavclient-cli and gave --action=disinfect,–silent as command line options.

The new shit is that my logs are flooded with “Not able to write to temporary directory (please specify another one)”.
In addition, when saving, it states “unexpected scan result for test content” which it never did before.
Apart from the web user being able to write to /tmp, specifying another one doesn’t help any further.
Also, behaviour of GData client didn’t change when invoked from the command line, even output is still the same.

So, what am I missing?
And apart from that: would anyone mind offering a GData option for Antivirus?
It’s not so seldom and as far as I’m concerned, it’s a company from my home town a mile away from me, so I would rather continue using it.

Kind regards,


I personally don’t use that program, but have you tried to switch to the web user, under which Nextcloud is running, and executed the program manually on the console? Does the same message appears again on the screen?

Yes, I did, and it works like usual with usual output.
It really seems to be a files antivirus Nextcloud app thing.
Unfortunately, I cannot do further testing at the moment as is down and I don’t get on the server and don’t know it’s current IP.
But thank you very much for replying!