Qnap Virtualization Station - Failed to import. File checksum error

Hey everybody,

I’m trying to set up nextcloud by using the Virtualization Station on a Qnap NAS (TS-453Be).
Installed firmware:
Virtualization Station: 3.1.1125

I’ve downloaded this pre-installed VM. Unfortunately, I’m not able to import the VM. Instead, I’m getting this error message:

Failed to import VM “Nextcloud_VM”. File checksum error.

I assume, that the Qnap has a problem with how the *ova-file of the VM got exported.

From the Qnap support site:

Notice: The *.ova and *.ovf formats are only supported by VMs (virtual machine) exported from VirtualBox v4 and VMware ESXi 5.0; the format *.vmx is supported by VMs exported from VMWare Workstation 8/9.

From the nextcloud VM - Github site (quoting @enoch85):

[…] it’s made with ESXi 5.5 compatibility.

The OVA is exported in Workstation 12 […]

Am I right? If so, what could I do to make the VM compatible with the Virtualization Station?

Looking forward to your help!

The Nextcloud VM has been successfully imported to some QNAPs, I’ve done it myself a few times. Though, it’s not recommended since it could be unstable. I also don’t remeber exactly the model of the QNAPs it worked on before.

My guess is that QNAP need to work on their Virtualization station, or that you need to update your QNAP. I don’t know, just guessing, but since it wokred in the past I’m surprised that it doesn’t work know.

Better yet, use VMware Player on any leftover laptop or PC that you can hide in a warderobe. It will do the work.

Hope it helps a bit at least.

Thank you very much for your fast reply.

The firmware on the NAS and the Virtualization Station are up to date. I’ve got this NAS because of the ability to run VMs and with nextcloud in mind. Using something else is not an option :wink:


1 Like

I had the same issues about a year ago: up to date QNAP box did not like OVAs.
Unless they were ancient old (VirtualBox 4) and even in this case it was 50/50.
Bottom line - do it from scratch. It works just fine…

Using not your own OVAs isn’t a very good idea to start with…

I was hoping to save me some time for the first setup :sweat_smile: But it looks like I’ll follow your advice and do it from scratch.

When installing, consider separating the system and data partition…

My QNAP was the 673 model with two M.2 SATA drives in RAID1.
So I installed Linux on it (20GB disk).

After that you create a new disk on “spinning rust” disks (5TB total in my case).
Attach as second to the Linux VM and mount it (somewhere; /NCDATA in my case).

When opening the URL for the first time, it asks you where to store the data.
Point it to this second (mounted) drive…

Thanks for your advice. To run the system on SSD(s) would be my preferred choice. But honestly - I’ve bought a new NAS and four new hard drives. For now it has to run on the HDDs and proof itself to my wife :wink:

edit: I can think of buying the PCIe -> m.2 extender with two SSDs in the future

I missed your model number (TS-453Be), it does not have built-in M.2 slots.
Mine is a TS-473 (also 4 drives), it has them… And can be configured as RAID1…

I’d still separate the system and data partitions, even when both on HDD.
So, if/when the OS does not boot (for whatever reason) you can mount the data
partition on another Linux VM and recover all the data…

Just to be clear: Install the nextcloud system somewhere and mount a folder from the NAS to the nextcloud VM where the data should be stored

Or are you talking about the Qnap system itself?

Everything on QNAP…

Install Linux VM + Nextcloud. Add second drive and mount it.
When finishing install and connecting with a browser, specify the second drive as data storage…

You could also build your own VM to get all the benefits from it: https://docs.hanssonit.se/s/W6fMouPiqQz3_Mog/virtual-machines-vm/d/bj0vl4ahv0jgrmfm0950/build-your-own-nextcloud-vm

Please remember to prepare 2 separate disks before you start the script. One for OS and one for DATA.

Hansson OVA probably has been build with hypervisor not compatible with virtualization station ( ESXi5.5?) or virtualization station is buggy

What I did:
download OVA from HanssonIT
Import to VM WKST 15
Clone (/current state/ create full clone)
Start in VM Workstation
login ncadmin/nextcloud
When script is started ctnl+c to cancel
Shut down vm (Power/shutdown guest)
Export as .OVF (File export to OVF)
Copy to NAS Storage
import to virtualization station (3.1.1125)
No checksum error

Good luck

1 Like

In case the VM does not work you can also try ContainerStation and import the ncp docker container.

The VM is built in VMware Workstation 15 with version 10 compatibility. So ESXi 5.5 should work.

I had the same problem. I have a copy of the VM OVA from Jan 2019 and it extracts. The current OVA downloaded Sep-30-2019 bombs out at ~ 20% with CRC error. I followed the work-around from hermannd but I don’t have a Pro Workstation copy, so I had to export to .OVF manually on the command line with VM Player. The process works and it is now running on my QNAP.

Note: I am a beginner so I don’t really know what I am doing, but for some reason I could not get the Jan 2019 download to work on the current version of QNAP in VirtualStation, it would bomb out and exit after changing the passwords. It was working in my Jan 2019 install, but this week I accidentally deleted the folder on my QNAP and needed to reinstall (no backup of the folder - ehh). The latest version once exported to OVF and imported, worked successfully.


1 Like