Public shared folder dont show the content files

public shared folder open on a smartphone browser (not in the app) like iphone 6/7 (safari and firefox) or samsung galaxy also when opend on ipad dosnt show the content-files, everything is white.
the same public shared link opend on pc-win/firefox/edge/chrome works fine.

Nextcloud version 11.0.7 and 13.0


Do you see any error messages in the logs? For example that the SSL handshake failed or something like that? You don’t block network traffic based on the client software used, right?

no errors in the log. network traffic without blockings…all “clients” are in the same network…the public-link works without problems on dif. pc/win10/7 with /firefox/edge/chrome…the same link on iphone/ipad opend normaly but shows no files…all is white

on 2 oc-installation (9 an 10) works fine :frowning:

1 Like

The thing is: it works for me. Just double checked and I can open public links and see all files existing in the shared folder.

I’m not sure however if I fully understand your problem. When you open the public link on the mobile devices you see the header (default blue) and from what you see on the mobile device, you can clearly tell that you are successfully connected to your Nextcloud server?
Or do you see absolutely nothing, just a complete white screen with no icons and no (blue) headers at all?

I saw issues with mobile devices on my server when my HTTPS were too secure (only the most modern ciphers). In that case android smartphones were not able to establish a secured connection (handshake failed). Your devices seem to be modern enough to have no problems however. Just to be sure: usually you can successfully connect to your nextcloud server, login with your account and perform every task on the web gui from your mobile devices, right?

What happens when you login to your account on the mobile device and navigate to the folder that you share publicly? Do you see the files then?
Do you use the app “file access control” and did you define some rules? If so, which?

I’m really wondering why you don’t see anything in the logs. If something fails it is usually mentioned somewhere (system logs (journalctl), web server logs (access or error) or nextcloud.log).

yes i can see the the header (blue), and yes i am successfully connected.
when i create also a user sharing and login with this, i can see the files, only the public share dont show the files.
no file access controls rules are in use, i have also try with disable the most of apps, without any changings :-(.
in nextcloud and webserver-logs is nothing is nothing to point out.
i think its a issue in html/css

Might be. In any case it’s really strange, that it works on other devices.

Can you post your web server config? I’m just trying to rule out some things and I remember that there could have been issues when certain blocks in the web server config are not in the correct order.

For example:

# Adding the cache control header for js and css files
# Make sure it is BELOW the PHP block
location ~ \.(?:css|js|woff|svg|gif)$ {
    #try_files $uri /index.php$uri$is_args$args;
    try_files $uri /index.php$request_uri;
    # Add headers to serve security related headers (It is intended to
    # have those duplicated to the ones above)
    # Before enabling Strict-Transport-Security headers please read into
    # this topic first.
    # add_header Cache-Control "public, max-age=15778463";
    #  includeSubDomains; preload;";
    # WARNING: Only add the preload option once you read about
    # the consequences in This option
    # will add the domain to a hardcoded list that is shipped
    # in all major browsers and getting removed from this list
    # could take several months.
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    # Optional: Don't log access to assets
    access_log off;

And maybe it is time not to fill out the issue template, so that we get a better idea about your server and the configuration :wink:

the only log-entry in nextcloud, that i found is.

stream_get_contents() expects parameter 2 to be integer, string given at /var/www/vhosts/

Betriebssystem ‪Debian 8.10‬
Produkt Plesk Onyx
Version 17.5.3 Update #40
PHP 7.1.14 PHP ausführen als FPM-Anwendung von ngnix bedient
Zusätzliche nginx-Anweisungen:

# Enable HSTS (HTTP Strict Transport Security)
add_header Strict-Transport-Security "max-age=15768000";
add_header X-Content-Type-Options nosniff;
add_header X-XSS-Protection "1; mode=block";
add_header X-Robots-Tag none;
proxy_hide_header X-Powered-By;

I’m trying my best to find information on the Internet, google a bit and describe as good as I can, what you could try and check. It would be really helpful if you provide the requested information, so that I can rule out some things.

Thank you very much for your efforts!

unfortunately I have no access to the apache/ngnix-webserver-config, only php-ini.

where can i find the issue-template?

further information, which may be helpful:
as mentioned above, it works with oc 9. x and oc x/10 without problems, all installations have exactly the same settings/configuration on the server.
i have also tried the various customizable settings on the server (php 7.0.27 - running PHP as an Apache application, and php 5.6.32 with fast-cgi from apache) unfortunately nothing has changed.


The issue template is available as app. You can find it under the category “Tools”.

Can you maybe share a folder with two example files and send my the public link in a private message?


Ok, I’m gonna try to make it work.
and where can I send private messages (sorry new here)

Hello everybody,

I would like to provide an update on this issue.
We were able to find the root cause of this issue and a workaround.

The thing was: only when accessing the public share in mobile view (usually smartphone or tablet, but reproducible with desktop version of firefox in mobile view as well), files were not listed and the page was only white.

As soon as we disabled the mobile view, all contained files were listed. Even on a smartphone when switching to desktop view.

From the browser’s debug console we saw that some javascript from the music app is running and caused an error.
Consequently we disabled the installed app “Music” (v0.5.6), reloaded the page and then files were listed even in mobile view.
The audioplayer app doesn’t cause this issue.

So I hope this will help anybody who stumbles accross this issue and searches for a solution. I hope and guess this issue will be solved in a future release.

@paulijar Can you have a look at that?

hallo schmu

wie gehts?

hast du erfahrung mit onlyoffice und collabora?
wenn ja, wo siehst du die die vorteile deines favoriten?
wie sind gem. deinen erfahrungen bezgl. system-mindestanforderungen?
sind die beiden eigentlich “frei verfügbar”, also open source?

lg aus der arschkalten schweiz…und es wird noch kälter, wobei ich annehme in münchen ist es auch nicht wäremr :slight_smile: