Proxy + Nextcloud

I’ve set my proxy in ubuntu, everything is okay there.
If my proxy wasn’t good on my ubuntu, i should not ping or connect to google via firefox.
Only Nginx/Nextcloud can’t join But I can ping it.


i bet it’s a matter of ngix-setup

Yep, i think so.

But i dunno how to set nginx behind a proxy

@Sanook curl is okay.

google is your friend here. but first… and before you’re gettingt into setting up ngix… pls show us your config.php and take care to remove sensitive data in it… (best you’d use the app that i suggested above because it mostly removes all sensitive data automatically) - just to make sure that the mistake isnt there

Before create this post, i’ve searcher a lot.

Im in this problem since 2 weeks. Thats why i come there.

This is my config.php.

Then you are not using the proxy

Did you install wireshark on your Ubuntu server?

Yes, i got BadTCP on the request.

My Nextcloud -> DNS to resolve = IP of

My nextcloud -> TCP request port 80 to IP of -> BadTCP, request blocked.

I dunno how to set Nginx to use the Proxy. That’s why i block.

I got a lot of information on Reverse proxy, but not set Nginx behind a proxy.

Why don’t you use Apache?

i’ve follow a tutorial. We got a lot of information of Nginx + Nextcloud but not that much for proxy :smiley:

I need someone who know Nginx settings.

Hello everyone.
I 'm glad to announce i’ve found my problem.

in the config/config.php i’ve to write my proxy of my compagny but not only that.

i’ve to write my “trusted proxies” like that :

‘trusted_proxies’ =>
array (
0 => ‘ip.of.proxy.compagny’,
‘proxy’ => ‘’,

And everything works well now ! im so glad.

Thanks for the help anyway everyone.