Prosody Install lua-lpty on Centos 7

Anyone has installed the above on Centos 7, the instructions: are not working for me.
Any one knows if a centos 7 RPM exist for the use of lua-lpty, i.e. ?

Note: I also attempted to to install the Experimental socket interface but no success on that front either:
[root@services20 ~]# telnet localhost 23664
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.
Traceback (most recent call last):
File “/opt/xmpp-cloud-auth/”, line 13, in
args = get_args(DEFAULT_LOG_DIR, DESC, EPILOG, ‘xcauth’)
File “/opt/xmpp-cloud-auth/xclib/”, line 108, in get_args
args = parser.parse_args(args=args, config_file_contents=config_file_contents)
File “/usr/lib/python2.7/site-packages/”, line 402, in parse_args
env_vars = env_vars)
File “/usr/lib/python2.7/site-packages/”, line 496, in parse_known_args
config_streams = self._open_config_files(args)
File “/usr/lib/python2.7/site-packages/”, line 717, in _open_config_files
for f in files]
IOError: [Errno 13] Permission denied: '/etc/xcauth.conf’
Connection closed by foreign host.
[root@services20 ~]#

I decided to give a try the build, usually I am no very good at this but it seems like this time it might of worked,
prosody seems to not complain:

Apr 27 12:26:59 mod_posix info Successfully daemonized to PID 5246
Apr 27 12:26:59 localhost:auth_external info External auth with pty command /opt/xmpp-cloud-auth/

To recap downloaded the source from here:

yum install lua-devel.x86_64 luajit-devel.x86_64 lua-socket-devel.x86_64

make && make install

The target install did not work for my distro so I manually moved the module where it could be found: /usr/lib64/lua/5.1
I also attempted to upload the module, sorry I believe this board does not allow it?

Tested with my first chat and pleased to confirm that the above worked. Regards to all.

Thanks for this info. Did the build for lua-lpty, thanks. But how did you install python-bcrypt? I tried
py-bcrypt, but it’s erroring out because of dependency issues.

This is what I get when trying to run

[root@xmpp xmpp-cloud-auth]# /opt/xmpp-cloud-auth/
Traceback (most recent call last):
File “/opt/xmpp-cloud-auth/”, line 3, in
from xclib.configuration import get_args
File “/opt/xmpp-cloud-auth/xclib/”, line 3, in
import requests
ImportError: No module named requests