Problems with Onlyoffice Nextcloud intergration

Hello,

I will try to provide all required details. Please let me know if i missed anything.

I am trying to setup integration between Onlyoffice and Nextcloud running on the same host/server.

I followed this guide

I am running Arch linux and installed the onlyoffice documentserver from AUR and setup the DB based on the Arch wiki.

So Documentserver is at version 5.4.1
Nextcloud it version 17.0.1
Onlyoffice NC app is latest version 3.0.2

Document server is running when i access /healthcheck it returns true

/welcome tells me all is running

However when i try to save the document server address on the Nextcloud config page i am given the following error

{“reqId”:“gmyXar7Ylvg4DXpTtl85”,“level”:3,“time”:“2019-11-28T10:29:49-04:00”,“remoteAddr”:“x.x.x.x”,“user”:“mgrondin”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings/address",“message”:“Request converted file on check error: Client error: GET http://office.mydomain.net:8443/cache/files/conv_check_1402127923_docx/output.docx/check_1402127923.docx?md5=ryLf7MUd2hDPo4ypVePgFQ&expires=1574952290&disposition=attachment&ooname=output.docx resulted in a 404 Not Found response:\n\n<html lang=“en”>\n\n<meta charset=“utf-8”>\nError\n\n\n

Cannot GET /erro (truncated…)\n”,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0”,“version”:“17.0.1.1”,“id”:“5ddfd9e087864”}

I think the problem is that it is trying to access at http instead of https but i’m not sure why it would do that… if i enter the same URL in my browser but change to https a empty docx file gets downloaded.

My apache virtualhost config

https://paste.linux.pizza/?06b2b91b395a9c09#doB7VXwHk1GIn5jYQcdtyoW6GwP2PSY/lsvFgVSLkf4=

I can’t find any other logs related to onlyoffice. Nothing in the main apache logs or in the nextcloud logs. there is a /var/log/onlyoffice folder but it is empty.

I have tried changing the document server log level to ALL but still no other log entry that i can find/see.

I feel like this is something so silly that i am missing but i can’t figure it out.

Let me know if you need anymore details to help me and thanks in advance for the help.